avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@realityforge.org>
Subject Re: avalon-framework **Util.java
Date Fri, 11 Apr 2003 13:03:52 GMT
On Fri, 11 Apr 2003 22:54, Berin Loritsch wrote:
> AFAIK, Log4J/LogKit don't need to be in the classpath--unless you are
> using the wrapper class.  As long as you never load the wrapper class
> you will never have any problems.  Cocoon has been using the LogKit in
> conjunction with A4 for years without problems--even though there is
> a Log4J wrapper in the JAR as well.

yep but what I want to do is use version X of LogKit/Log4j in container and 
version Y in the components. I have had to help quite a few users who used 
differing versions of Log4j get Phoenix setup - PITA. If they could use 
whatever version they wanted and it didn't effect the container then that 
would be great.

-- 
Cheers,

Peter Donald
---------------------------------------------------------
Clarke's Third Law: "Any technology distinguishable from 
magic is insufficiently advanced".
---------------------------------------------------------


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Mime
View raw message