avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@apache.org>
Subject Re: [Fortress] Dispose bug
Date Sat, 15 Feb 2003 17:30:42 GMT
J Aaron Farr wrote:
> --- J Aaron Farr <jaaronfarr@yahoo.com> wrote:
> 
>>Apparently the attatchment didn't work right.  Here's the patch file (I
>>hope).
>>:)
>>
>>jaaron
>>
> 
> 
> My email client is acting buggy.
> 
> One last try, this time cut and paste:
> 
> FortressServiceManager
> ----[snip]-----------------------------------------------------------------
> 
> 134c134
> <             m_used.put( component, handler );
> ---
> 
>>            m_used.put( component.toString(), handler );
> 
> 165c165,167
> <         final ComponentHandler handler = (ComponentHandler)m_used.remove(
> component );
> ---
> 
>>        final ComponentHandler handler = (ComponentHandler)m_used.remove(
> 
> component.toString() );
> 
> ----[snip]-----------------------------------------------------------------
> 
> Again, this change properly handles disposable components for me.  Can anyone
> else confirm the use of disposable in Fortress?

It's the same logic used in ECM.... Hmmm.  I believe the problem may
have to do with the fact that the component is proxied....


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Mime
View raw message