avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylvain.wal...@anyware-tech.com>
Subject Re: Altrmi requires JDK 1.4 + license problem
Date Mon, 27 Jan 2003 22:53:46 GMT
Paul Hammant wrote:

> Sylvain,
>
>> While building Excalibur with JDK 1.3, I had an error on 
>> AbstractSocketStreamSSHInvocationHandler in the 
>> org.apache.excalibur.altrmi.client.impl.socket package : this classes 
>> uses "new Socket()", which was protected up to JDK 1.4.
>
>
> Will be fixed soon.
>
>> Is altrmi intended to run on JDK 1.4 only ?
>
>
> No it is an anomoly.


Good :-)

>> Moreover, this class relies on JSch, which is LGPL, and AFAIK we 
>> cannot include LGPL'ed libraries in Apache CVS repositories.
>
>
> I think you mean GPL.


No, no, I mean LGPL. I've always been told, that, although we legally 
can link to LGPL'ed code, it's use is prohibited to prevent any derived 
work based on LGPL'ed libraries to reside on Apache's CVS repositories. 
This was even said no later than today on cocoon-dev (see [1]).

> Plenty of Apache code imports LGPL.  I can point you to the FSF page 
> if you like.


Yes, please, and also on this Apache code importing LGPL. Other than 
yours of course ;-)

Sylvain

[1] http://marc.theaimsgroup.com/?t=104361122100004&r=1&w=2

-- 
Sylvain Wallez                                  Anyware Technologies
http://www.apache.org/~sylvain           http://www.anyware-tech.com
{ XML, Java, Cocoon, OpenSource }*{ Training, Consulting, Projects }



--
To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>


Mime
View raw message