avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@apache.org>
Subject RE: [VOTE] (recap) New name for Version 5 ComponentManager
Date Fri, 14 Jun 2002 00:07:31 GMT
At 05:40 PM 6/13/2002 +0200, you wrote:

> > From: Berin Loritsch [mailto:bloritsch@apache.org]
> >
> > ServiceLocator (XXXXLocator): 3 (Me, Leo Sutic, Stephen McConnel)
>Can someone to a newbie check on "You get your *Components* from
>the *Service*Locator"?
>I was against ServiceLocator not because I didn't see Components
>as being/providing a service, but if we are talking about
>Components, then we should apply that name throughout.
>I really dislike the shift in terminology we have here...

For all practical purposes

Component Orientated Programming == Service Orientated Programming

The distinction between the two being that in SOP you are usually required 
to explicitly define the interface of communication between components. In 
Avalon we enforce this in most cases (at least Phoenix and ECM enforce it - 
not sure about other containers).

So there is little difference I think.


Peter Donald
"Faced with the choice between changing one's mind,
and proving that there is no need to do so - almost
everyone gets busy on the proof."
              - John Kenneth Galbraith

To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>

View raw message