avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen McConnell <mcconn...@osm.net>
Subject Re: [VOTE] (recap) New name for Version 5 ComponentManager
Date Thu, 13 Jun 2002 15:41:19 GMT

Leo Simons wrote:

>>I like the quote from Stephen Haberman:
>>"I agree; I'm very new to Avalon, but given my naïve
>> impression of what the component is supposed to do,
>> I like XXXLocator better also. As a newbie, I can
>> understand the concept quicker than with the
>> XXXDirectory."
>This is very important (I will know its meaning anyway =). I'd like to
>get input from other users.
>>That would make (on official voting):
>>ServiceLocator (XXXXLocator): 3 (Me, Leo Sutic, Stephen McConnel)
>>ComponentDirectory: 2 (Leo Simmons, MarcusCrafter)
>I'm okay with ComponentXXXX (within some limits). I don't think it is
>smart to start using the word "service"...it might look good in
>management meetings ("so, does it support Web Services?"), but it is
>I'll even give you a -1 on that if neccessary :P. We do COP here, not
>SOP. Or are we changing that too?

I think Berlin meant the ComponentLocator/ServiceLocator pair. A  CL for
Avalon 4.1 could be introduced providing it maintained the Component return
value.  An equivalent SL could be added to the framework service package.  
In both cases XxxxxLocator would be the base type for XxxxManager.
In A5 the service package would presumable dissapear because the
differences would would have been folded into a new component package
name. The result A5 component package would not container a CM.



Stephen J. McConnell

digital products for a global economy

To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>

View raw message