avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <vadim.gritse...@verizon.net>
Subject RE: [Summary] Avalon 5 ComponentManager interface
Date Wed, 12 Jun 2002 15:37:30 GMT
> From: Leo Sutic [mailto:leo.sutic@inspireinfrastructure.com]
 
<snip/>

>     public void doStuff () {
>         Transformer transformer = transformerManager.getTransformer
();
>         try {
>         } finally {
>             transformerManager.release (transformer);
>             // OR
>             transformer.release();
>             // OR
>             transformer.endDocument();
>         }
>     }

Why not standardize on one approach? I.e., leave only
transformerManager.release (transformer) or transformer.release(), and
don't have zoo of different methods doing the same?


> As seen above, for components whose interface makes them
thread-unsafe,
> there *must* be a method, either in the associated manager, or in the
> component itself, that, when called by the client, indicates that
> the client is finished using the component.

Especially if there is consensus that method must exist... Why not
standardize on method name?

<snip/>

Vadim



--
To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>


Mime
View raw message