avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Berin Loritsch" <blorit...@apache.org>
Subject RE: Target JDK version
Date Mon, 24 Jun 2002 13:51:54 GMT
> From: Leo Sutic [mailto:leo.sutic@inspireinfrastructure.com] 
> 
> I just realized that dynamic proxies aren't available in JDK 
> 1.2. (They appeared in JDK1.3)
> 
> Is framework required to support JDK1.2 or is it a "should"/"would 
> be nice if"?


There is nothing in Framework that *requires* JDK 1.3 or higher.
Therefore, the JDK 1.2 is fine for Framework.

However, for containers, JDK 1.3 provides a number of useful features.
We should decide on a component/container by component/container
basis.  As a general rule, JDK 1.3 is not a bad requirement.


--
To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>


Mime
View raw message