avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Berin Loritsch" <blorit...@apache.org>
Subject RE: [VOTE] (recap) New name for Version 5 ComponentManager
Date Thu, 13 Jun 2002 15:09:04 GMT
So far here are the votes:

3 ComponentDirectory
4 ComponentLocator/ServiceLocator
1 ComponentLookup (writein from Nicola Ken Barrozi)
1 ComponentResolver (writein from Marcus Crafter)

Breakdown even further:

ComponentDirectory
------------------
Marcus Crafter
Berin Loritsch
Leo Simmons

XXXXLocator
-----------
Leo Sutic
Gonzalo A. Diethelm
Stephen McConnel
Stephen Haberman


Now I realize that at least one or two of these is not
a committer, but since they are users/potential users
their oppinions should be used to come to a decision.

After I read Leo's link to the J2EE patterns page, I
really like the idea of "ServiceLocator" as the name.

I like the quote from Stephen Haberman:

"I agree; I'm very new to Avalon, but given my naïve
 impression of what the component is supposed to do,
 I like XXXLocator better also. As a newbie, I can
 understand the concept quicker than with the
 XXXDirectory."

Between Leo's page and Stephen's quote, I would like
to change my vote (yes I can be swayed :) ) to
"ServiceLocator"

That would make (on official voting):

ServiceLocator (XXXXLocator): 3 (Me, Leo Sutic, Stephen McConnel)
ComponentDirectory: 2 (Leo Simmons, MarcusCrafter)

And the two write-ins.


--
To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>


Mime
View raw message