avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Berin Loritsch" <blorit...@apache.org>
Subject [VOTE] New name for Version 5 ComponentManager
Date Thu, 13 Jun 2002 13:18:43 GMT
We seem to be in agreement that ComponentManager is not the correct name
for what we are trying to enforce with the CM.  Therefore I suggest we
vote on the name--that way when we refer to it in our emails we can
refer to the new name and avoid confusion over which version CM we
are talking about (esp. for lurkers).

So far we have two candidates that have popped up in the past mails:

* ComponentDirectory
* ComponentLocator

Remember that the CM is representing a *lookup mechanism*.  It is
designed
to be much simpler than JNDI, although to provides a similar service
(only
for components though).

I vote +1 for ComponentDirectory

ComponentDirectory has the proper connotation, and does not imply an
index
as someone suggested (ever heard of a phone directory?).


"They that give up essential liberty to obtain a little temporary safety
 deserve neither liberty nor safety."
                - Benjamin Franklin


--
To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>


Mime
View raw message