avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <j...@socialchange.net.au>
Subject Re: Is the Command package of Excalibur usable?
Date Sat, 04 May 2002 00:48:43 GMT
On Fri, May 03, 2002 at 10:20:36AM -0700, Clover, James wrote:
[on Command..]

> I attempted to use the one from the scratchpad released with Excalibur 4.1,
> but received a NullPointerException when I tried (I've placed the stack
> trace from the log below).  I then tried to build it from CVS where I
> noticed it had been moved as a subpackage of Event.  However, I couldn't get
> the CVS build to compile - it complained about some missing packages (util
> for example).

Could you post the logs here? Event should be buildable just by typing
'ant' in the event/ directory.

...
> java.lang.NullPointerException
>         at
> org.apache.avalon.excalibur.thread.impl.ResourceLimitingThreadPool.getWorker
> (ResourceLimitingThreadPool.java:267)
...

I think you may be using an old version of the code. Line 267 doesn't
contain a throws clause. That might also explain the build failure if
your CLASSPATH isn't clean.


--Jeff


--
To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>


Mime
View raw message