avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <j...@socialchange.net.au>
Subject FIXED [Problem]: Excalibur.jar does not contain all classes
Date Wed, 24 Apr 2002 13:39:27 GMT
I've worked around this problem by having two intermediate <jlink>
tasks, and then <jlink>ing their outputs together.

Please let us know if the problem persists. FYI, my avalon-excalibur.jar
is 419582 bytes, and 'wc -l' reports 358 classes.


--Jeff


On Wed, Apr 24, 2002 at 11:12:50PM +1000, Jeff Turner wrote:
> I am having the same problem. For me, the temporary jar doesn't have the
> classes either, so it looks like it's the <jlink> bug.
> 
> Not sure what to do about this :/ jlink is hopelessly buggy. I'll have a
> look tomorrow and see if I can find what triggers the bug.
> 
> 
> --Jeff
> 
> 
> On Wed, Apr 24, 2002 at 10:01:47AM +0200, Carsten Ziegeler wrote:
> > Hi,
> > 
> > when I build excalibur everything is building fine, but the resulting
> > avalon-excalibur.jar does not contain all classes, for example the
> > io, the monitor or the xmlbundle subprojects are missing.
> > 
> > The interesting thing is that the temporary jar created by the jlink
> > task does contain all classes, so it seems that the jar task does
> > not get all files from the temporary jar.
> > 
> > Any hint what could get wrong here?
> > 
> > Carsten
> > 
> > --
> > To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>
> 
> --
> To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>


Mime
View raw message