avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent Tence <Vincent.TE...@gemplus.com>
Subject RE:Instrument questions + Altrmi questions
Date Mon, 29 Apr 2002 21:26:39 GMT
I've identified the problem. It seems that the main thread is waiting on a
synchronized block because
AltrmiFactory.setHostContext() does not return.

Anybody can help on this?

Thanks,
Vincent

> -----Original Message-----
> From: Vincent Tence [mailto:Vincent.TENCE@gemplus.com]
> Sent: Monday, April 29, 2002 4:40 PM
> To: 'Avalon Developers List'
> Subject: RE: Instrument questions
>
>
> Leif,
>
> I'm facing a problem with the InstrumentManager running under
> Tomcat. I have
> a simple yet powerful
> MVC2 framework designed to integrate with Avalon nicely and I
> want to add
> instrumentation to it.
>
> I configured the framework to use the
> InstrumentComponentManager and I added
> a few Instruments to the
> Front Component to record things like number of requests received,
> successful, request latency, ...
>
> The problem occurs when I connect the client to the altrmi server. The
> connection seems to go fine,
> but I when I try to access the menu InstrumentManagers, my
> client hang up.
> I tried to remove all my instrumentables to run the manager
> with only the
> ComponentManager and itself as instrumentables,
> but it still hang up.
>
> Any idea?
>
> Thx,
> Vincent
>
>
> --
> To unsubscribe, e-mail:
> <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:avalon-dev-help@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>


Mime
View raw message