avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leo Simons" <leosim...@apache.org>
Subject RE: Release requirements?
Date Mon, 01 Apr 2002 07:35:09 GMT
> On Mon, 1 Apr 2002 07:25, Leo Simons wrote:
> > There's nothing about JDKs. Should compile & run with version
> > 1.3 and 1.4, perhaps?
> 
> 1.2 is the default target for most things that I am using. The exception 
> being Phoenix which uses the jdk1.3 proxies and framework that 
> can optionally 
> build a JDK1.4 Logger if JDK1.4 present. 
> 
> Is there any other jdk dependencies ?

I can't really tell. All I ever use is 1.3 and it never chokes
on anythin' =) I'm just talking 'bout what should be 'requirments'.

> > Also, should follow that last legal stuff sent out over
> > committers@apache.org :)
> 
> Which particular bit is that? The excalibur jars all place the 
> LICENSE.txt in 
> META-INF/, phoenix no longer distributes non-Apache jars.
<snip>
> Ones we need to investigate;
> jakarta-avalon-excalibur/all/lib/jaxen-full.jar 
> jakarta-avalon-excalibur/all/lib/saxpath.jar 

This bit, I guess. It is probably best to check stuff like this
before any new release, hence the comment.

> > On a related note, how do we handle versioning and
> > compatibilities (which could get very messy with all
> > those jars lying around).
> 
> I plan to write a task that automagically generates a manifest 
> that declares 
> dependencies on other jars via the standard "Optional Packages" mechanism 
> (previously known as "Extension" mechanism). Actually I have 
> already written 
> it .. just needs time to dcecouple it from the project it was 
> used in and add 
> it into ant ;)

well that's a happy surprise =)

grz,

- Leo


--
To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>


Mime
View raw message