avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antti Koivunen <anryo...@users.sourceforge.net>
Subject ServiceManager/Serviceable -> Director/Actor?
Date Sat, 16 Feb 2002 16:58:40 GMT
Hi there,

When I first stumbled into Cocoon 1 a few years back, I remember really 
liking the intuitive names of the core interfaces, Director and Actor. 
Given the confusion surrounding Component/ServiceManager, and the 
somewhat valid argument that Object != Component != Service, I think 
this might be something to consider.

The main purpose of Component/ServiceManager is to look up an object 
that matches the specified role (behavioral interface), so the idea 
would go well together with the Director-Actor naming scheme. Having 
intuitive and 'fun' names for the core interfaces could also make the 
framework more approachable (Composable???). Programming is serious 
enough as it is :)

Personally I don't have any problems with the name ServiceManager. 
"Providing the service specified by the role" makes perfect sense to me, 
and I also like the term Serviceable. But as these are the names we'll 
be looking at for a long time, I thought everybody might want to have a say.

The new classnames could be:


These remind me of the practical names I've used in AOP (e.g. Group, 
Member), but some people might prefer technical terms. The idea could be 
extended with terms like agent, audition and studio (though not sure for 
what purpose).

So, is this way too silly or actually something to consider?

(Stabilizing ServiceManager is of course the first priority. The final 
name of the interface is a separate issue.)

(: A ;)

To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>

View raw message