avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@apache.org>
Subject Re: Build problem in Phoenix
Date Mon, 10 Dec 2001 11:49:29 GMT
On Mon, 10 Dec 2001 22:06, Leif Mortenson wrote:
> I tried doing a dist build of the Phoenix project and am getting the
> following error:
>
> E:\Jakarta\jakarta-avalon-phoenix\build.xml:206: Failed to copy
> E:\Jakarta\jakarta-avalon\src\documentation\diagrams\images\uml\package_thr
>ead.png to
> E:\Jakarta\jakarta-avalon-phoenix\build\documentation\diagrams\images\uml\p
>ackage_thread.png due to null
>
> It is being caused by the following block at line 206 (and again at 317) in
> the build.xml file: <copy todir="${build.context}" filtering="on">
> <fileset dir="${context.dir}">
> <exclude name="resources/**"/>
> <exclude name="xdocs/**"/>
> </fileset>
> </copy>
>
> The problem, I think, is that the png files are getting the filter run
> on them and failing.
> If I change to the following, it works great.
> <copy todir="${build.context}" filtering="on">
> <fileset dir="${context.dir}">
> <exclude name="diagrams/images/**"/>
> <exclude name="resources/**"/>
> <exclude name="xdocs/**"/>
> </fileset>
> </copy>
>
> Do these images need to be copied in another copy task?

actually - they don't need to be copied at all ;) I think I may have fixed it 
but then again I never got that exception locally ;) Does it work for you now 
?

-- 
Cheers,

Pete

---------------------------------------------------
"It is easy to dodge our responsibilities, but we 
cannot dodge the consequences of dodging our 
responsibilities." -Josiah Stamp 
---------------------------------------------------

--
To unsubscribe, e-mail:   <mailto:avalon-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-dev-help@jakarta.apache.org>


Mime
View raw message