avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From giacomo <giac...@apache.org>
Subject Re: Pooling Problems
Date Wed, 05 Sep 2001 15:06:05 GMT
On Wed, 5 Sep 2001, Laran Coates wrote:

> Hi there.  I'm working on something using some of the Pooling classes and
> I'm having problems with the Logger in the DefaultPool.
>
> This is more or less what I'm doing.
>
> <code>
>
> class MClass
> extends AbstractLoggable {
>
>   public MClass()
>   {
>      init();
>   }
>
>   void init()
>   {
>
>     Pool mPool =
>       new SoftResourceLimitingPool(
>         Class.forName( "com.blah" ), 1, 10 );
>
>     mPool.setLogger( getLogger() );
>
>     mPool.initialize();
>
>     // Problem happens on next line...
>     System.out.println( mPool.get().toString() );
>
>   }
>
> }
>
> </code>
>
> When I run that code the get() call to the Pool throws a NPE at line 148 in
> DefaultPool.
>
> Am I not initializing the Pool or the Logger properly?
> Anyone got any ideas?

What is getLogger() returning? Did your MClass got a logger?

Giacomo

>
> Laran Coates
> Azurn Networks
>
>
> _________________________________________________________
> Do You Yahoo!?
> Get your free @yahoo.com address at http://mail.yahoo.com
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: avalon-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: avalon-dev-help@jakarta.apache.org
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: avalon-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: avalon-dev-help@jakarta.apache.org


Mime
View raw message