avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ulrich Mayring <u...@denic.de>
Subject Problem running avalon-soapdemo.sar
Date Wed, 19 Sep 2001 08:29:41 GMT
Hello,

I've successfully built cornerstone and, as instructed, copied the
avalon-soapdemo.sar to my phoenix/apps directory. When started, it
produces:

java.lang.NoClassDefFoundError: javax/net/SocketFactory
        at
electric.net.socket.tcp.TCPSocketFactory.<init>(TCPSocketFactory.java:30)
        at java.lang.Class.newInstance0(Native Method)
        at java.lang.Class.newInstance(Class.java:237)
        at
electric.net.socket.SocketChannel.getFactory(SocketChannel.java:112)
        at
electric.net.socket.SocketServer.createServerSocket(SocketServer.java:193)
        at
electric.net.socket.SocketServer.startup(SocketServer.java:64)
        at electric.net.http.WebServer.startup(WebServer.java:179)
        at
electric.net.http.WebServer.startWebServer(WebServer.java:160)
        at electric.server.http.HTTP.startup(HTTP.java:91)
        at electric.server.http.HTTP.startup(HTTP.java:69)
        at electric.server.http.HTTP.startup(HTTP.java:52)
        at
org.apache.avalon.cornerstone.blocks.soapification.glue.Glue.start(Glue.java:62)

Thanks in advance for any pointers,

Ulrich

-- 
Ulrich Mayring
DENIC eG, Systementwicklung

---------------------------------------------------------------------
To unsubscribe, e-mail: avalon-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: avalon-dev-help@jakarta.apache.org


Mime
View raw message