avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject Re: [PATCH] RE: proposed: CLI Args improvement
Date Mon, 17 Sep 2001 09:24:22 GMT
On Mon, 17 Sep 2001 05:40, Michael McKibben wrote:
> I've attached a patch for CLArgsParser and ClutilTestCase which adds the
> requested feature. 

committed - taah!

> In trying to be consistent with getArguments(), I added
> two new methods: getArgumentById(int) and getArgumentByName(String). In
> retrospect, should they be renamed getOptions(), and getOptionByXXX since
> they return CLOption? 

Not sure - it prolly does make more sense using "option" - what does everyone 
else think?

> The patched ClutilTestCase adds a test case for
> validating the two new methods. I created the patches using cvs diff -u
> relative to the project root directory.




| Never argue with an idiot, they'll drag you down to |
| their level, and beat you with experience           |

To unsubscribe, e-mail: avalon-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: avalon-dev-help@jakarta.apache.org

View raw message