avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <j...@socialchange.net.au>
Subject Re: Excalibur Junit
Date Tue, 21 Aug 2001 11:20:10 GMT
I don't know what's going on here.. last week, I was experiencing just what 
you're talking about. Tests took >2 mins on an 800mhz Duron. Changing
fork="true" to fork="false" made no difference.

Now, after having done a clean checkout, unsetting ANT_HOME, and running
'./build.sh test', it takes 27 secs. The XSLT bit takes under 2 secs.


Btw, the following tests currently fail:

testSubstituteErrorFile     "file:src/test/test.xml" not found.
testActiveMonitorFailure    "File not changed"

--Jeff

On Tue, Aug 21, 2001 at 08:39:03PM +1000, Peter Donald wrote:
> Hi,
> 
> Could someone who knows junit do the following. For some reason the tests run 
> ungodly slow. I suspect it is because it is forking the JVm and then doing 
> lots of work with XML and then XSL a bit later. While this is nice if you 
> want to generate reports etc it is no good for normal development. So there 
> has to be someway where none of this stuff reports/results etl al is 
> generated and everything is done in JVM. So if so could someone do it.
> 
> -- 
> Cheers,
> 
> Pete

---------------------------------------------------------------------
To unsubscribe, e-mail: avalon-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: avalon-dev-help@jakarta.apache.org


Mime
View raw message