avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philip Antoniades <phi...@bangstate.com>
Subject Re: Problem creating/using JdbcConnectionPool
Date Mon, 02 Jul 2001 15:58:28 GMT
berin,

thank you!

i'm looking forward to your paper - if you want a 'guinea pig programmer' to read 
through it, i'd be more than happy to volunteer. i have many questions (that can 
probably be guessed by the one i asked) better suited for an 'avalon-user' list 
that i've been holding...

philip

Berin Loritsch wrote:

> Philip Antoniades wrote:
> 
>>hello,
>>
>>I've read about all the docs I can get my hands on, and i suspect i
>>still dont get how to properly deploy Components through avalon. But why
>>does this code:
>>
> 
> Because you didn't use the Component.  Try this:
> 
> DataSourceComponent ds = new JdbcDataSource();
> ds.setLogger(this.getLogger());
> ds.compose(this.manager);
> ds.configure(conf);
> ds.initialize();
> 
> 
> The configuration should look like this:
> 
> <jdbc-connection>
>   <!-- if this is not an Oracle databse change oradb -->
>   <pool-controller min="5" max="10" oradb="true"/>
> 
>   <dburl>jdbc:oracle:thin:@ORADB:localhost:1521</dburl>
>   <user>joe</user>
>   <password>blow</password>
> </jdbc-connection>
> 
> 
> Also make sure you have already loaded the driver class into the
> classloader.
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: avalon-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: avalon-dev-help@jakarta.apache.org


Mime
View raw message