avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leo Sutic" <leo.su...@inspireinfrastructure.com>
Subject RE: [Proposal] Should we introduce a new idiom for Components?
Date Thu, 17 May 2001 13:10:42 GMT
But the problem still remains:

interface DataSourceComponent {
    String ROLE =
"org.apache.avalon.excalibur.datasources.DataSourceComponentSelector";

    Connection getConnection();
}

Shouldn't the role be
"org.apache.avalon.excalibur.datasources.DataSourceComponent"? According to
the general rule?

Maybe:

interface DataSourceComponent {
    String ROLE =
"org.apache.avalon.excalibur.datasources.DataSourceComponent";
    String SELECTORROLE =
"org.apache.avalon.excalibur.datasources.DataSourceComponentSelector";
    String MULTIPLEROLEROOT = "org.apache.avalon.excalibur.datasources.";

    Connection getConnection();
}

I'll wait for the paper, but I still see problems with your approach.

/LS



---------------------------------------------------------------------
To unsubscribe, e-mail: avalon-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: avalon-dev-help@jakarta.apache.org


Mime
View raw message