avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leo Simons" <m...@leosimons.com>
Subject RE: [Proposal] Should we introduce a new idiom for Components?
Date Thu, 17 May 2001 09:18:05 GMT
+1

cheers,

LSD

> I am specifically thinking about the Excalibur components.  In 
> order to enforce
> the Role names being correct, I am proposing that we augment the 
> work interface
> with the following idiom:
> 
> 
> interface DataSourceComponent {
>     String ROLE = 
> "org.apache.avalon.excalibur.datasources.DataSourceComponentSelector";
> 
>     Connection getConnection();
> }

---------------------------------------------------------------------
To unsubscribe, e-mail: avalon-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: avalon-dev-help@jakarta.apache.org


Mime
View raw message