avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject RE: more on lifecycle methods
Date Tue, 24 Apr 2001 10:03:33 GMT
At 11:25  24/4/01 +0200, Leo Simons wrote:
>In response to Peter:
>> no idea - I would -1 the Executable name in favour of something else
>> (Animatable or Active???). Still can't think of a good name for
>> Interruptable thou ;)
>Component == Passive entity
>Composer/Composable == Active entity
>So that's not a real option.

Do you like Animated then ?

>Why was it again that Interruptable was a bad name? Perhaps...
>...scratches head...can't think of anything else either ;/

Interruptable implies either of the following

interface Interruptable {} //ie maarker interface
interface Interruptable 
  void interrupt();

because that is a fairly established pattern. Don't know of anything better
though .... may scrounge through saw thesaurus/dictionary.

>> -1 on adding commands at this stage
>I agree. Untested code should not go in a beta. But do we move there in
>the future or not?

yep - but I am not sure the proposed design was something desirable yet.
What you called Commands are traditionally called Task/Jobs. Before we
adopt anything we should check out existing research (and there is a lot
about it) aswell as prototype it a bit ;)



| "Faced with the choice between changing one's mind, |
| and proving that there is no need to do so - almost |
| everyone gets busy on the proof."                   |
|              - John Kenneth Galbraith               |

To unsubscribe, e-mail: avalon-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: avalon-dev-help@jakarta.apache.org

View raw message