avalon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@apache.org>
Subject Re: Pool Rework
Date Fri, 02 Mar 2001 13:09:29 GMT
Peter Donald wrote:
> At 01:05  1/3/01 -0500, Berin Loritsch wrote:
> >I am working on a new Pool implementation using the algorithm previously
> >discussed (based on the JdbcConnectionPool) that would work properly.
> >The issue I am dealing with at this point in time is that we need the
> >ObjectFactory to handle the end of an Object's life.  In Cocoon it would
> >call the destroy(), stop(), and other end of lifecycle events for an
> >Avalon Component.  I propose this:
> >
> >ObjectFactory {
> >   Object newInstance(); //fully prepared object
> >   Class getCreatedClass(); //Class object
> >   void decommission(Object); //takes care of end of life handling.
> >}
> >
> >This is important for ResourceLimiting implementations.
> yer that seems fine ;) Its at times like these you *almost* wish you were
> using C++ .... until of course you remember what it was like to use C++ ;)

Speaking of that....

I am going to have to completely rewrite my abstract pool because I hosed
up the get()/put() methods.  Your formatting for the source code has got
my head beant in all sorts of directions, so I will reimplement using the
Cocoon standards which are much easier to read IMNSHO ;).

I much prefer to use "this." instead of "m_" because it is explicit, and
the compiler knows exactly what I do.  I can't tell you the number of times
I had to help folks with bugs that were merely scoping issues.  Both our
conventions address that issue (because according to your convention only
member variables have "m_").  It's just that my IDE will give me all the
methods and variables that are visible to me simply by typing in "this."
so there is less typing and less memory I have to worry about.

   I am not trying to start a new flame war on coding styles!!!  That has
   been hashed out many times on this list, and does not need to be hashed
   out any more!

   I am merely stating that I have a tougher time thinking in the coding
   standards on the Avalon framework.  I know Peter has a script that auto
   formats the code, so personally I would rather commit correct code and
   let him format it ;P

I will get that done as soon as I possibly can...

View raw message