avalon-apps-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Wallace <rwall...@a--i--m.com>
Subject Sevak Catalina problems
Date Fri, 22 Nov 2002 01:36:36 GMT
Hey all,

I've been trying to get Sevak Catalina implementation and demo to run in
Phoenix.  I haven't had any success so far.

My first problem was that Phoenix didn't want to even try and create the
blocks.  It kept giving me the following message on the console:

Unable to create BlockInfo as are unable to locate resource
"org/apache/avalon/apps/sevak/blocks/catalina/startup/Bootstrap.xinfo".

So, I did some looking and sure enough it looks as though the class
o.a.a.a.sevak.blocks.catalina.startup.Bootstrap is no longer used (in
fact, it's been deleted), but is still referenced from the
src/demo/conf/catalina-assembly.xml file.

I looked though the classes available in the blocks.catalina package and
found the replacement CatalinaSevakBootstrap class.   I changed the
catalina-assembly.xml file to use this as instead of the old Bootstrap
block.

Things seem to be better now.  Phoenix at least creates the blocks and
starts going through their lifecycles.  But, when it calls initiailze()
on the CatalinaSevakBoostrap class, it fails with a
ClassNotFoundException, saying it can't find
org.apache.catalina.loader.StandardClassLoader.  I noticed this was
getting added to the sar in the common/lib directory, so I tried to put
it in the SAR-INF/lib directory thinking that would make it available to
the class loader when the block is being initialized.  No luck.

I've tried everything I can think to try for the moment, any one else
have any ideas?

Note: I've attached a diff of the changes I made to the
catalina-assembly.xml file.  While poking around I also noticed some
oddities in the build.xml file where two jar were being created:
sevak-catalina.jar, which was empty, and sevak-catalina-impl.jar which
had the actual class and xinfo files in it.  Oh, and it was generated
from the jakarta-avalon-apps/sevak directory (didn't want any changes
anywhere else to be included by accident).

-- 
Richard Wallace <rwallace@a--i--m.com>
AIM, Inc.

Mime
View raw message