avalon-apps-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Krieg" <dkr...@kc.rr.com>
Subject Re: Sevak Catalina problems
Date Fri, 22 Nov 2002 16:37:46 GMT
There is a working sevak servlet container -- using Jetty -- that is all set
to go.  However,
if you are specifically required to use Tomcat-Catalina as the embedded
server, I can
dedicate time to doing this ASAP.  What is your time schedule?


----- Original Message -----
From: "Timothy Bennett" <exterminatorx@comcast.net>
To: "Avalon Applications Developers List"
<avalon-apps-dev@jakarta.apache.org>
Sent: Friday, November 22, 2002 10:16 AM
Subject: Re: Sevak Catalina problems


> Very timely, Daniel...
>
> I'm new to Phoenix, but have plans to build a commercial server based on
the
> framework.  At a minimum, I wanted an embedded database (hsql) and an
> embedded servlet container (sevak-catalina).  I am very interested in your
> re-work of the Sevak-Catalina as soon as you can.  Though I'm new to
Phoenix
> and Avalon framework, I'm starting to get a bit more familiar with it.
Not
> sure if I can be of much help, but I could make myself available to
provide
> some help if needed.
>
> Timothy
>
> ----- Original Message -----
> From: "Daniel Krieg" <dkrieg@kc.rr.com>
> To: "Avalon Applications Developers List"
> <avalon-apps-dev@jakarta.apache.org>
> Sent: Thursday, November 21, 2002 10:49 PM
> Subject: Re: Sevak Catalina problems
>
>
> > Richard,
> >
> > Actually, CatalinaSevakBootstrap was replaced with
> > o.a.a.a.sevak.blocks.catalina.startup.Bootstrap,
> > but as you have pointed out, this has been deleted (or never made it
into
> > CVS).
> >
> > I was working on SevakCatalina a few months ago but job responsibilities
> > have pulled me away.
> > I returned to this project just this week to find for myself the same
> issues
> > you are encountering.
> > I unfortunately did not keep a local copy of my code, so I will need to
> > reimplement several things.
> >
> > Revisiting this project, I now have a better perspective regarding
Tomcat
> > integration into
> > Phoenix.  Given another go at it, I will be able to create a far better
> > solution.  For example,
> > in October Peter Donald added the Excalibur Loader into the BlockContext
> to
> > provide
> > an implementation for ClassLoading and thus
> > org.apache.catalina.loader.StandardClassLoader
> > (which you is giving you ClassNotFoundException) is not needed.
> >
> > What is your timeline for needing SevakCatalina?  I think I will be have
a
> > little more time to
> > where I can put this together in a far better implementation.
> >
> > > Hey all,
> > >
> > > I've been trying to get Sevak Catalina implementation and demo to run
in
> > > Phoenix.  I haven't had any success so far.
> > >
> > > My first problem was that Phoenix didn't want to even try and create
the
> > > blocks.  It kept giving me the following message on the console:
> > >
> > > Unable to create BlockInfo as are unable to locate resource
> > >
"org/apache/avalon/apps/sevak/blocks/catalina/startup/Bootstrap.xinfo".
> > >
> > > So, I did some looking and sure enough it looks as though the class
> > > o.a.a.a.sevak.blocks.catalina.startup.Bootstrap is no longer used (in
> > > fact, it's been deleted), but is still referenced from the
> > > src/demo/conf/catalina-assembly.xml file.
> > >
> > > I looked though the classes available in the blocks.catalina package
and
> > > found the replacement CatalinaSevakBootstrap class.   I changed the
> > > catalina-assembly.xml file to use this as instead of the old Bootstrap
> > > block.
> > >
> > > Things seem to be better now.  Phoenix at least creates the blocks and
> > > starts going through their lifecycles.  But, when it calls
initiailze()
> > > on the CatalinaSevakBoostrap class, it fails with a
> > > ClassNotFoundException, saying it can't find
> > > org.apache.catalina.loader.StandardClassLoader.  I noticed this was
> > > getting added to the sar in the common/lib directory, so I tried to
put
> > > it in the SAR-INF/lib directory thinking that would make it available
to
> > > the class loader when the block is being initialized.  No luck.
> > >
> > > I've tried everything I can think to try for the moment, any one else
> > > have any ideas?
> > >
> > > Note: I've attached a diff of the changes I made to the
> > > catalina-assembly.xml file.  While poking around I also noticed some
> > > oddities in the build.xml file where two jar were being created:
> > > sevak-catalina.jar, which was empty, and sevak-catalina-impl.jar which
> > > had the actual class and xinfo files in it.  Oh, and it was generated
> > > from the jakarta-avalon-apps/sevak directory (didn't want any changes
> > > anywhere else to be included by accident).
> > >
> > > --
> > > Richard Wallace <rwallace@a--i--m.com>
> > > AIM, Inc.
> > >
> >
> >
>
> --------------------------------------------------------------------------
> --
> > ----
> >
> >
> > > --
> > > To unsubscribe, e-mail:
> > <mailto:avalon-apps-dev-unsubscribe@jakarta.apache.org>
> > > For additional commands, e-mail:
> > <mailto:avalon-apps-dev-help@jakarta.apache.org>
> >
> >
> > --
> > To unsubscribe, e-mail:
> <mailto:avalon-apps-dev-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> <mailto:avalon-apps-dev-help@jakarta.apache.org>
> >
> >
>
>
>
> --
> To unsubscribe, e-mail:
<mailto:avalon-apps-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:avalon-apps-dev-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:avalon-apps-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:avalon-apps-dev-help@jakarta.apache.org>


Mime
View raw message