aurora-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Renan DelValle <renanidelva...@gmail.com>
Subject Re: Review Request 62590: WIP: Update to Thrift 0.10.0
Date Fri, 10 Nov 2017 02:04:15 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/62590/#review190663
-----------------------------------------------------------



I'm all for the upgrade to Thrift 0.10.0 but we should announce plans to upgrade ASAP to the
mailing lists because it'll break every go thrift client due to https://issues.apache.org/jira/browse/THRIFT-3467
. It says it was included first in 0.11.0, but commit history shows it was actually included
in 0.10.0 https://github.com/apache/thrift/commit/ca714c4397ed78bd880f0dd76526e3817ecc08f0
. It caused a huge amount of breakage in gorealis when I tried upgrading the dependancy for
kicks so we should give everyone a fair warning.

- Renan DelValle


On Sept. 26, 2017, 1:50 p.m., Stephan Erb wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/62590/
> -----------------------------------------------------------
> 
> (Updated Sept. 26, 2017, 1:50 p.m.)
> 
> 
> Review request for Aurora and Bill Farner.
> 
> 
> Repository: aurora
> 
> 
> Description
> -------
> 
> Update to Thrift 0.10.0 (https://github.com/apache/thrift/blob/master/CHANGES)
> 
> Included changes:
> 
> * Switch to cmake rather than building with make. The cmake build is more lenient with
its build requirments. We would have needed to upgrade the system bison on MacOS otherwise.
> * The Java `hashcode` option has been removed as it is now the default.
> 
> 
> ToDo / Questions:
> 
> * Rebuild the Aurora image to include Thrift 0.10. Until this is done, one needs to manually
run `sudo apt-get install flex bison cmake build-essential` within the vagrant box to ensure
Thrift can be bootstrapped.
> * The Gradle workaround looks strange. If it is really required we should extract it
into a separate patch.
> * The Pants build is complaining about the usage of `new_style` option. See if we can
get to work around it.
> * Do we want to maintain some patches to ensure we are just building the required Thrift
subset? Is this worth the effort?
> 
> 
> Diffs
> -----
> 
>   3rdparty/python/requirements.txt 0c04b98e791c5de1985724304f384e8dbade8c19 
>   build-support/packer/build.sh 7b7914c11e376a5f7ba7a5ee69fa0962e9bca379 
>   build-support/thrift/AURORA-1727.compiler.cpp.Makefile.in.patch 77c966caa3d1f644241bcc2b1968bc9306c56689

>   build-support/thrift/AURORA-1727.compiler.cpp.src.generate.t_java_generator.cc.patch
42300b43a8f72e45c96b975e5d3a6a7bd0283529 
>   build-support/thrift/AURORA-1727.lib.py.setup.py.patch 11c7b13341e156f3686511cb40ab13c1256203a6

>   build-support/thrift/Makefile f440b610afe321af663e393a29eebda7af7bd7a8 
>   build.gradle 851bab52fd389bc9577a6938f646bb29bae06139 
>   buildSrc/src/main/groovy/org/apache/aurora/build/ThriftPlugin.groovy fc2bc9082dae2c63aa578c05dc89feb346260a67

>   gradle.properties PRE-CREATION 
>   pants.ini f25e1d1a50f457325dbbabf327c31d760cb90339 
>   src/main/java/org/apache/aurora/scheduler/storage/mem/Util.java c28fb65010af5e3db925487929d4e0e12b4101a4

> 
> 
> Diff: https://reviews.apache.org/r/62590/diff/1/
> 
> 
> Testing
> -------
> 
> ./build-support/jenkins/build.sh
> ./src/test/sh/org/apache/aurora/e2e/test_end_to_end.sh
> 
> 
> Thanks,
> 
> Stephan Erb
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message