aurora-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolás Donatucci <ndonatu...@medallia.com>
Subject Re: Review Request 60942: Remove task level resource fields from thrift interface and db
Date Wed, 08 Nov 2017 14:37:52 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/60942/
-----------------------------------------------------------

(Updated Nov. 8, 2017, 2:37 p.m.)


Review request for Aurora, Joshua Cohen, Stephan Erb, and Zameer Manji.


Changes
-------

Removed DB Migration


Bugs: AURORA-1707
    https://issues.apache.org/jira/browse/AURORA-1707


Repository: aurora


Description (updated)
-------

Removed task level resource fields from the DB and the thrift-API.
To do this, a new DB migration was added. When upgrading, it just drops the task level resource
fields. When downgrading, it creates the fields again and populates them with information
from the task_resource table.

IMPORTANT: Having an issue when going from 0.18.0 to patched version and then to 0.18.0 again.

"E1106 19:16:28.752 [LeaderSelector-0, SchedulerLifecycle] Caught unchecked exception: com.google.common.util.concurrent.UncheckedExecutionException:
java.lang.IllegalArgumentException: Multiple entries with same key"

[4:23] 
org.apache.aurora.scheduler.storage.db.views.DbTaskConfig@182dcd47. To index multiple values
under a key, use Multimaps.index.

Will investigate more, but I'm not really getting what is going on.

Issue Related: AURORA-1707


Diffs (updated)
-----

  RELEASE-NOTES.md 5122c49354811bdb53bd5a0febb29c5d8a736b0d 
  api/src/main/thrift/org/apache/aurora/gen/api.thrift c869493c06499340d73e1b219e17a0d7d8b5ead9

  src/main/java/org/apache/aurora/scheduler/base/TaskTestUtil.java 7c223eae69503fe1d5bf34c430438637abcbcb9b

  src/main/java/org/apache/aurora/scheduler/storage/db/TaskConfigManager.java d2eb6aa6e4a155b2d28debab2ca10dfc76d57213

  src/main/java/org/apache/aurora/scheduler/storage/db/TaskConfigMapper.java cda55c55680a19ed421299a8949299b21949787b

  src/main/java/org/apache/aurora/scheduler/storage/db/migration/V004_CreateTaskResourceTable.java
af106a8a9ee8c14122e98bcc0ec44b616f21d61f 
  src/main/java/org/apache/aurora/scheduler/storage/db/views/DbTaskConfig.java 138cd5316adc73eed24fc7accc53885dd5d5bee5

  src/main/python/apache/aurora/client/cli/diff_formatter.py 78717774aa3fbaf83a5fb850bc9f9f4a4038d70f

  src/main/python/apache/aurora/client/cli/jobs.py b79ae56bee0e5692cacf1e66f4a4126b06aaffdc

  src/main/resources/org/apache/aurora/scheduler/storage/db/TaskConfigMapper.xml 5422183e4a1fe122fc0e1aa871aa75ae102e322d

  src/main/resources/org/apache/aurora/scheduler/storage/db/schema.sql 7a86f47af67adb3e488381d30ddf424549deefbc

  src/test/java/org/apache/aurora/scheduler/http/TestUtils.java 689482c9f6c49bcca781834566edeb975d2f3af2

  src/test/java/org/apache/aurora/scheduler/storage/db/RowGarbageCollectorTest.java 74c9d1d2fba94971106c148ac76d5a76dab6a7b4

  src/test/java/org/apache/aurora/scheduler/thrift/Fixtures.java 43e32eede27bbf26363a3fd1ca34ffe6f8c01a73

  src/test/java/org/apache/aurora/scheduler/updater/UpdateAgentReserverImplTest.java 1bc2a778ad3f1543a055023f9ec3fe9e4a9523e3

  src/test/python/apache/aurora/client/cli/test_status.py b0b7f96d8148f0dd1f6f45d1c5c6f830cabcfd5d

  src/test/python/apache/aurora/client/cli/util.py 476b8c2951f315db0b9983bb8fbed0d7efc155aa

  src/test/python/apache/aurora/config/test_resources.py 25a20f0b702189744a26b85053db34c37ff5b03c



Diff: https://reviews.apache.org/r/60942/diff/9/

Changes: https://reviews.apache.org/r/60942/diff/8-9/


Testing
-------

src/test/sh/org/apache/aurora/e2e/test_end_to_end.sh

1 - Created a new VM with a fresh Aurora 0.18.0, ran the tests so that the db would have something.
Then upgraded to patched version and ran the tests again. Everything worked and task level
resource fields were no longer there.
2 - Created a new VM with a fresh patched version, ran the tests so that the db would have
something. Then downgraded to 0.18.0 and ran the tests again. Everything worked and task level
resources were there, with the correct backfilled values.


Thanks,

Nicolás Donatucci


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message