aurora-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Sirois" <>
Subject Re: Review Request 39784: Upgrade Aurora to pants 0.0.55.
Date Tue, 10 Nov 2015 20:06:55 GMT

This is an automatically generated e-mail. To reply, visit:

(Updated Nov. 10, 2015, 1:06 p.m.)

Review request for Aurora, Joe Smith, Bill Farner, and Zameer Manji.


Fixup aurora api thrift deps to work with commons.

Previously the aurora api specified no thrift requirement and let pants
resolve it.  Upgrading pants leads to a conflict with twitter.commons
pinned `thrift==0.9.1` requirements so we work around by surfacing the
same pinning.  The resolution solution for aurora itself and any higher
level clients built on aurora libs is either unchanged or of no import:
+ If the 3rdparty has no thrift dep they don't care by definition, the
  new solution will pick exactly `0.9.1` instead of floating up to -
  right now `0.9.3` for example - a good thing.
+ If the 3rdparty pins their thrift requirement, nothing changes for
  them whether they use `pip` or `pex` or `pants`; their higher level
  dep trumps since all 3 tools do a breadth 1st search and 1st level

Also restore a TODO to kill and un-pin setuptools, let the
pants defaults (more modern setuptools) work.                                     | 2 ++
 api/src/main/thrift/org/apache/aurora/gen/BUILD | 7 +++++++
 api/src/main/thrift/org/apache/thermos/BUILD    | 5 ++++-
 pants.ini                                       | 7 ++-----
 4 files changed, 15 insertions(+), 6 deletions(-)

Bugs: AURORA-1499

Repository: aurora


This also brings Aurora up to pex 1.1.0 and switches to the pants
setup script; an equivalent to gradlew.  Of note, the script is checked
in with chmod 555, its not intended to be edited.

Although pants now includes checkstyle built in, conversion to use it is
left for follow-on work.

Also adapt make-pycharm-virtualenv which previously relied on the local
bootstrapping of pants - now hidden away by the pants setup script.

 .pantsversion                                  |   1 -
 3rdparty/python/requirements.txt               |   2 +-
 BUILD                                          |  25 -------------                                    |  19 ++++++++--
 build-support/jenkins/                 |   2 +-
 build-support/pants_requirements.txt           |  30 ---------------
 build-support/python/make-pycharm-virtualenv   |  11 +++++-
 build-support/python/update-pants-requirements |  34 -----------------
 pants                                          | 102 +++++++++++++++++++++++++++++++++++++++-----------
 pants.ini                                      |  63 ++-----------------------------
 src/main/python/apache/aurora/tools/BUILD      |   2 +-
 src/main/python/apache/thermos/observer/BUILD  |   2 +-
 12 files changed, 114 insertions(+), 179 deletions(-)

Diffs (updated)

  .pantsversion 78bae5bb6d254d014e35be0b828497f1509d80bd 
  3rdparty/python/requirements.txt 27a2c77047c26ab380fc739e7c5c532bf590c6ee 
  BUILD 7de0c74b03ba609576867ba96885858c0908f2e9 75698a5ded7914a4d22ab7ae769d9ed1576531e4 
  api/src/main/thrift/org/apache/aurora/gen/BUILD 2dcc46d9658044d96f4f1b3634f29ae1d446e0d7

  api/src/main/thrift/org/apache/thermos/BUILD 6b13949aceb830b962a7098ae65462151119d752 
  build-support/jenkins/ 5606bb157cb117a588f363382d7c8841ae957138 
  build-support/pants_requirements.txt 6eefa7175f7bda7bea23466936e451113a2d86f7 
  build-support/python/make-pycharm-virtualenv d7bd41835bcd9a8fe62ea522a177bfa7830a897b 
  build-support/python/update-pants-requirements 82f7c5136fad52f4bc2a458beb5f34f0cc7f6cec

  pants 6f3526ef76fc37e3215b0673bcb1725d205a1c95 
  pants.ini dd4ba668586ee5bd1c888f315429e661adb6a480 
  src/main/python/apache/aurora/tools/BUILD e5ac75838cbe98bbef4e35f6f300b6a6df5e7de5 
  src/main/python/apache/thermos/observer/BUILD d7eedabc0930711530b45ac98a1159e69d1a0c00 



Locally: `./pants test.pytest --no-fast src/test/python:: -- -v`

Also generated a pycharm project via:
Confirmed library source linking worked as did running unit tests
via the IDE.

Also grepped for pants commands in the repo, found `binary` and `setup-py`
and confirmed these worked.


John Sirois

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message