aurora-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Farner" <wfar...@apache.org>
Subject Review Request 32051: Detect an invalid .auroraversion expansion and provide a helpful error message.
Date Fri, 13 Mar 2015 16:41:19 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32051/
-----------------------------------------------------------

Review request for Aurora and Kevin Sweeney.


Bugs: AURORA-1169
    https://issues.apache.org/jira/browse/AURORA-1169


Repository: aurora


Description
-------

Help users notice and make progress more quickly when fatefully attempting to build with a
Windows host OS.

An alternative approach would be to not rely on the symlink here, but i'm not confident that
this would kick the can down the road to one of the numerous other places we rely on symlinks.

This does not fix AURORA-1169, but i propose that we do this to make it clear earlier that
Windows as a build platform is not currently supported.  Given the number of native dependnecies
we have, i think this is the most sane course for the project today.


Diffs
-----

  build.gradle dc366d4339b83af9e1fea663fe8e5860702644e9 

Diff: https://reviews.apache.org/r/32051/diff/


Testing
-------

Ran the build with a dummy version value, got this:

```
$ ./gradlew build
:buildSrc:compileJava UP-TO-DATE
:buildSrc:compileGroovy UP-TO-DATE
:buildSrc:processResources UP-TO-DATE
:buildSrc:classes UP-TO-DATE
:buildSrc:jar UP-TO-DATE
:buildSrc:assemble UP-TO-DATE
:buildSrc:compileTestJava UP-TO-DATE
:buildSrc:compileTestGroovy UP-TO-DATE
:buildSrc:processTestResources UP-TO-DATE
:buildSrc:testClasses UP-TO-DATE
:buildSrc:test UP-TO-DATE
:buildSrc:check UP-TO-DATE
:buildSrc:build UP-TO-DATE

FAILURE: Build failed with an exception.

* Where:
Build file '/home/wfarner/code/aurora/build.gradle' line: 53

* What went wrong:
A problem occurred evaluating root project 'aurora'.
> 
  *******************************************************************************
  The application version string read by gradle is invalid.  This is known to
  happen when building on Windows, or within vagrant with a Windows host.
  You can work around this issue by cloning git _within_ vagrant and building
  from there.
  
  For more details, please see https://issues.apache.org/jira/browse/AURORA-1169
  *******************************************************************************


* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to
get more log output.

BUILD FAILED

Total time: 6.14 secs
```


Thanks,

Bill Farner


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message