aurora-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Sweeney" <kevi...@apache.org>
Subject Re: Review Request 28610: Use requirements.txt for 3rdparty/python.
Date Tue, 02 Dec 2014 23:09:21 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/28610/
-----------------------------------------------------------

(Updated Dec. 2, 2014, 3:09 p.m.)


Review request for Aurora, Joshua Cohen and Brian Wickman.


Changes
-------

Remove commented-out lines.


Bugs: AURORA-617
    https://issues.apache.org/jira/browse/AURORA-617


Repository: aurora


Description
-------

Use requirements.txt for 3rdparty/python.

Also drop an unused Flask dependency and upgrade CherryPy to 3.6.0 (which has a functioning
version on PyPI and thus doesn't need a custom repository set in the BUILD file).


Diffs (updated)
-----

  3rdparty/python/BUILD 91cc1e83b5d286f6db8315d8b69afdb96d61e21f 
  3rdparty/python/requirements.txt PRE-CREATION 
  src/main/python/apache/thermos/observer/bin/BUILD 9793132526ba7bba731d838c576b819a39068905


Diff: https://reviews.apache.org/r/28610/diff/


Testing
-------

./pants src/test/python:all


Thanks,

Kevin Sweeney


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message