aurora-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David McLaughlin" <da...@dmclaughlin.com>
Subject Re: Review Request 22429: Add getConfigGroupSummary API endpoint
Date Thu, 12 Jun 2014 17:39:28 GMT


> On June 12, 2014, 1:22 a.m., Maxim Khutornenko wrote:
> > src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java,
line 425
> > <https://reviews.apache.org/r/22429/diff/1/?file=606598#file606598line425>
> >
> >     s/public/private?

Done.


> On June 12, 2014, 1:22 a.m., Maxim Khutornenko wrote:
> > src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java,
line 436
> > <https://reviews.apache.org/r/22429/diff/1/?file=606598#file606598line436>
> >
> >     Better use: 
> >     
> >     IJobKey jobKey = JobKeys.assertValid(IJobKey.build(mutableJobKey));

Done.


> On June 12, 2014, 1:22 a.m., Maxim Khutornenko wrote:
> > src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java,
line 440
> > <https://reviews.apache.org/r/22429/diff/1/?file=606598#file606598line440>
> >
> >     Any reason to do a deep copy of it here?

Fixed.


> On June 12, 2014, 1:22 a.m., Maxim Khutornenko wrote:
> > src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java,
line 442
> > <https://reviews.apache.org/r/22429/diff/1/?file=606598#file606598line442>
> >
> >     This could be merged with activeTasks to eliminate naming confusion.

I think it's more readable this way. 


> On June 12, 2014, 1:22 a.m., Maxim Khutornenko wrote:
> > src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java,
line 443
> > <https://reviews.apache.org/r/22429/diff/1/?file=606598#file606598line443>
> >
> >     s/byInstance/taskByInstance?

Done.


> On June 12, 2014, 1:22 a.m., Maxim Khutornenko wrote:
> > src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java,
line 452
> > <https://reviews.apache.org/r/22429/diff/1/?file=606598#file606598line452>
> >
> >     Merge it with okResponse(...)?

I also think it's more readable this way. Also consistent with other functions.


- David


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/22429/#review45449
-----------------------------------------------------------


On June 12, 2014, 5:38 p.m., David McLaughlin wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/22429/
> -----------------------------------------------------------
> 
> (Updated June 12, 2014, 5:38 p.m.)
> 
> 
> Review request for Aurora, Kevin Sweeney and Maxim Khutornenko.
> 
> 
> Bugs: AURORA-519
>     https://issues.apache.org/jira/browse/AURORA-519
> 
> 
> Repository: aurora
> 
> 
> Description
> -------
> 
> Add getConfigGroupSummary API endpoint, which returns a TaskConfig -> Set<InstanceId>
struct for active tasks. This will let us paginate active tasks, or drop TaskConfig from the
getTasksStatus response in the future. 
> 
> 
> Diffs
> -----
> 
>   src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java d9c3a1eecec4995b0539429b1079ff63118fb9e5

>   src/main/thrift/org/apache/aurora/gen/api.thrift e72bcfb57d288d585307549be5d74067ab08c42b

>   src/test/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterfaceTest.java
299679618f135f29bbf4e6372585ae46a1224a27 
>   src/test/java/org/apache/aurora/scheduler/thrift/aop/ForwardingThrift.java cfe45d1137ca3dec56b0cc4f8612faeedbf44acf

> 
> Diff: https://reviews.apache.org/r/22429/diff/
> 
> 
> Testing
> -------
> 
> ./gradlew build
> 
> 
> Thanks,
> 
> David McLaughlin
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message