aurora-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Farner" <wfar...@apache.org>
Subject Re: Review Request 20174: Link thermos_observer in default path in Vagrant example.
Date Wed, 09 Apr 2014 21:57:02 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/20174/#review39946
-----------------------------------------------------------


This is also fixed in https://reviews.apache.org/r/20067/, which is waiting on Kevin for a
review.

- Bill Farner


On April 9, 2014, 8:44 p.m., Johan Liseborn wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/20174/
> -----------------------------------------------------------
> 
> (Updated April 9, 2014, 8:44 p.m.)
> 
> 
> Review request for Aurora.
> 
> 
> Repository: aurora
> 
> 
> Description
> -------
> 
> It seems thermos_observer, thermos_executor, and gc_executor did not get copied or linked
to somewhere in the default PATH after the refactor to only one instance under Vagrant. This
resulted in /etc/init/aurora-thermos-observer.conf to fail, and thermos_observer where not
started.
> 
> I am unsure where the proper place to link is, but I tried to mimic the structure from
before the refactor, i.e. link them under /usr/local/bin (and updated the run script accordingly).
> 
> Also note that I am not terribly familiar with Aurora, so there may be things I have
misunderstood. The only thing I noticed was the thermos_observer did not start automatically,
and this seems to be fixed by the patch.
> 
> 
> Diffs
> -----
> 
>   examples/vagrant/provision-dev-cluster.sh ec9554356cd789d308a5adce4784b04abe64ab95

>   examples/vagrant/upstart/aurora-thermos-observer.conf 6db85aad5b0c2d484656bfb5d5bfa4ad4c9b3342

> 
> Diff: https://reviews.apache.org/r/20174/diff/
> 
> 
> Testing
> -------
> 
> I have tested the patch using Vagrant on OS X 10.9.2, and it seems to work as intended.
> 
> 
> Thanks,
> 
> Johan Liseborn
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message