aurora-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephan Erb (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AURORA-1794) Scheduler fails to start if -enable_revocable_ram is toggled
Date Thu, 13 Oct 2016 09:29:21 GMT

     [ https://issues.apache.org/jira/browse/AURORA-1794?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stephan Erb updated AURORA-1794:
--------------------------------
    Affects Version/s: 0.16.0

> Scheduler fails to start if -enable_revocable_ram is toggled
> ------------------------------------------------------------
>
>                 Key: AURORA-1794
>                 URL: https://issues.apache.org/jira/browse/AURORA-1794
>             Project: Aurora
>          Issue Type: Story
>    Affects Versions: 0.16.0
>            Reporter: Stephan Erb
>            Assignee: Stephan Erb
>
> The scheduler does not start if {{-enable_revocable_ram}} is set:
> {code}
> Exception in thread "main" java.lang.IllegalStateException: A value cannot be changed
after it was read.
>         at com.google.common.base.Preconditions.checkState(Preconditions.java:174)
>         at org.apache.aurora.common.args.Arg.set(Arg.java:54)
>         at org.apache.aurora.common.args.ArgumentInfo.setValue(ArgumentInfo.java:128)
>         at org.apache.aurora.common.args.OptionInfo.load(OptionInfo.java:131)
>         at org.apache.aurora.common.args.ArgScanner.process(ArgScanner.java:368)
>         at org.apache.aurora.common.args.ArgScanner.parse(ArgScanner.java:200)
>         at org.apache.aurora.common.args.ArgScanner.parse(ArgScanner.java:178)
>         at org.apache.aurora.common.args.ArgScanner.parse(ArgScanner.java:155)
>         at org.apache.aurora.scheduler.app.SchedulerMain.applyStaticArgumentValues(SchedulerMain.java:226)
>         at org.apache.aurora.scheduler.app.SchedulerMain.main(SchedulerMain.java:197)
> {code}
> This is an unfortunate oversight at my end. When introducing the feature, I deferred
the e2e test. It 'worked' in a manual test - at least that is what I believed. Probably, I
had only added the flag to the config in the repo, but not to the one that was actually started
in vagrant.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message