aurora-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Farner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AURORA-989) aurora client v2 dont have "version" command
Date Thu, 08 Jan 2015 03:48:34 GMT

    [ https://issues.apache.org/jira/browse/AURORA-989?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14268788#comment-14268788
] 

Bill Farner commented on AURORA-989:
------------------------------------

I suggest we no longer use a {{version}} command, but use a standard {{--version}} argument,
which argparse handles: https://docs.python.org/2/library/argparse.html#action

> aurora client v2 dont have "version" command
> --------------------------------------------
>
>                 Key: AURORA-989
>                 URL: https://issues.apache.org/jira/browse/AURORA-989
>             Project: Aurora
>          Issue Type: Bug
>          Components: Client
>    Affects Versions: 0.7.0
>            Reporter: Bhuvan Arumugam
>
> aurora v2 client should include this command. there's no way to find version of client
running.
> {code}
> [bhuvan@build ~/projects/mesos/incubator-aurora]$ ./dist/aurora2.pex version
> usage: aurora2.pex [-h] {task,quota,cron,job,config,sla,beta-update} ...
> aurora2.pex: error: argument noun: invalid choice: 'version' (choose from 'task', 'quota',
'cron', 'job', 'config', 'sla', 'beta-update')
> {code}
> {code}
> [bhuvan@build ~/projects/mesos/incubator-aurora]$ ./dist/aurora_client.pex version
> Aurora client build info:
> 	sha: 6c71b72e5b5f4da3346ea4036e39096a4eb9cd97
> 	date: Tuesday Jan 06, 2015 21:42:55
> Aurora API version: APIVersion(major=3)
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message