aurora-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Igor (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AURORA-972) Impossible to build Thermos.pex following instructions
Date Tue, 16 Dec 2014 13:43:13 GMT

    [ https://issues.apache.org/jira/browse/AURORA-972?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14248240#comment-14248240
] 

Igor commented on AURORA-972:
-----------------------------

I've finally figure out how to build Mesos.Native 0.20.1 and installed it via "easy_install",
but, still get the same error while building Thermos.pex:
Unsatisfiable: Cannot satisfy requirements: [PythonRequirement(mesos.native==0.20.1)]

When I do "pip freeze", I get the "mesos.native=0.20.1" in the list.


> Impossible to build Thermos.pex following instructions
> ------------------------------------------------------
>
>                 Key: AURORA-972
>                 URL: https://issues.apache.org/jira/browse/AURORA-972
>             Project: Aurora
>          Issue Type: Story
>          Components: Documentation, Executor
>         Environment: CentOS 6.5, Mesos 0.20.1
>            Reporter: Igor
>
> I’ve followed all the installation instructions but can’t find the appropriate thermos.pex
> Started to reverse engineer what Vagrant is doing and landed on the whole process of
“pants”
> ./pants src/main/python/apache/aurora/executor/bin:thermos_executor
> Fails with the error:
> Unsatisfiable: Cannot satisfy requirements: [PythonRequirement(mesos.native==0.20.1)]
> Apparently I can’t find the instructions on how to build this egg.  Please advise.
>   Thanks a lot



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message