aurora-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bhuvan Arumugam (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AURORA-588) test_runner_integration test fail in rhel6.5/py27/vagrant
Date Fri, 18 Jul 2014 00:08:04 GMT

     [ https://issues.apache.org/jira/browse/AURORA-588?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bhuvan Arumugam updated AURORA-588:
-----------------------------------

    Attachment: pants-test-failure.log

the test failure output

> test_runner_integration test fail in rhel6.5/py27/vagrant
> ---------------------------------------------------------
>
>                 Key: AURORA-588
>                 URL: https://issues.apache.org/jira/browse/AURORA-588
>             Project: Aurora
>          Issue Type: Story
>          Components: Build
>    Affects Versions: 0.5.0
>            Reporter: Bhuvan Arumugam
>         Attachments: pants-setuptools.log, pants-test-failure.log
>
>
> It's specific to this combination: rhel6.5/py27/vagrant.
> The pants target {{./pants src/test/python:all -vxs}} fail, with following traceback.
> {code}
> Saving PEX file to /home/bhuvan/projects/mesos/incubator-aurora/build-support/pantsbuild.pants-0.0.17.pex.tmp
> Built pantsbuild.pants-0.0.17.pex
> warning: tag '0.5.1-snapshot' is really 'quark/0.5.1-snapshot' here
> **** Failed to install setuptools-2.2. stdout:
> **** Failed to install setuptools-2.2. stderr:
> /usr/lib64/python2.6/distutils/dist.py:266: UserWarning: Unknown distribution option:
'zip_safe'
>   warnings.warn(msg)
> /usr/lib64/python2.6/distutils/dist.py:266: UserWarning: Unknown distribution option:
'extras_require'
>   warnings.warn(msg)
> /usr/lib64/python2.6/distutils/dist.py:266: UserWarning: Unknown distribution option:
'test_suite'
>   warnings.warn(msg)
> /usr/lib64/python2.6/distutils/dist.py:266: UserWarning: Unknown distribution option:
'entry_points'
>   warnings.warn(msg)
> usage: - [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
>    or: - --help [cmd1 cmd2 ...]
>    or: - --help-commands
>    or: - cmd --help
> error: invalid command 'bdist_egg'
> Traceback (most recent call last):
>   File "/home/bhuvan/projects/mesos/incubator-aurora/build-support/pantsbuild.pants-0.0.17.pex/.bootstrap/_twitter_common_python/pex.py",
line 223, in execute
>     self.execute_entry(entry_point, args)
>   File "/home/bhuvan/projects/mesos/incubator-aurora/build-support/pantsbuild.pants-0.0.17.pex/.bootstrap/_twitter_common_python/pex.py",
line 271, in execute_entry
>     runner(entry_point)
>   File "/home/bhuvan/projects/mesos/incubator-aurora/build-support/pantsbuild.pants-0.0.17.pex/.bootstrap/_twitter_common_python/pex.py",
line 294, in execute_pkg_resources
>     runner()
>   File "/home/bhuvan/.pex/install/pantsbuild.pants-0.0.17-py2-none-any.whl.f0d69afaa686ab1c0173d143d9c0cdd58bade4ae/pantsbuild.pants-0.0.17-py2-none-any.whl/pants/bin/pants_exe.py",
line 179, in main
>     _run()
>   File "/home/bhuvan/.pex/install/pantsbuild.pants-0.0.17-py2-none-any.whl.f0d69afaa686ab1c0173d143d9c0cdd58bade4ae/pantsbuild.pants-0.0.17-py2-none-any.whl/pants/bin/pants_exe.py",
line 147, in _run
>     build_graph)
>   File "/home/bhuvan/.pex/install/pantsbuild.pants-0.0.17-py2-none-any.whl.f0d69afaa686ab1c0173d143d9c0cdd58bade4ae/pantsbuild.pants-0.0.17-py2-none-any.whl/pants/backend/python/commands/build.py",
line 55, in __init__
>     self.interpreter_cache.setup(filters=interpreters)
>   File "/home/bhuvan/.pex/install/pantsbuild.pants-0.0.17-py2-none-any.whl.f0d69afaa686ab1c0173d143d9c0cdd58bade4ae/pantsbuild.pants-0.0.17-py2-none-any.whl/pants/backend/python/interpreter_cache.py",
line 207, in setup
>     self._setup_paths(setup_paths, filters)
>   File "/home/bhuvan/.pex/install/pantsbuild.pants-0.0.17-py2-none-any.whl.f0d69afaa686ab1c0173d143d9c0cdd58bade4ae/pantsbuild.pants-0.0.17-py2-none-any.whl/pants/backend/python/interpreter_cache.py",
line 172, in _setup_paths
>     self._setup_interpreter(interpreter)
>   File "/home/bhuvan/.pex/install/pantsbuild.pants-0.0.17-py2-none-any.whl.f0d69afaa686ab1c0173d143d9c0cdd58bade4ae/pantsbuild.pants-0.0.17-py2-none-any.whl/pants/backend/python/interpreter_cache.py",
line 156, in _setup_interpreter
>     return _resolve(self._config, interpreter, logger=self._logger)
>   File "/home/bhuvan/.pex/install/pantsbuild.pants-0.0.17-py2-none-any.whl.f0d69afaa686ab1c0173d143d9c0cdd58bade4ae/pantsbuild.pants-0.0.17-py2-none-any.whl/pants/backend/python/interpreter_cache.py",
line 99, in _resolve
>     interpreter = _resolve_interpreter(config, interpreter, setuptools_requirement, logger=logger)
>   File "/home/bhuvan/.pex/install/pantsbuild.pants-0.0.17-py2-none-any.whl.f0d69afaa686ab1c0173d143d9c0cdd58bade4ae/pantsbuild.pants-0.0.17-py2-none-any.whl/pants/backend/python/interpreter_cache.py",
line 48, in _resolve_interpreter
>     logger=logger)
>   File "/home/bhuvan/.pex/install/pantsbuild.pants-0.0.17-py2-none-any.whl.f0d69afaa686ab1c0173d143d9c0cdd58bade4ae/pantsbuild.pants-0.0.17-py2-none-any.whl/pants/backend/python/interpreter_cache.py",
line 70, in _resolve_and_link
>     dist_location = installer.bdist()
>   File "/home/bhuvan/.pex/install/twitter.common.python-0.5.9-py2-none-any.whl.23043f5ce1ad6bf7f5e1c3be34f880aabf7b0a4c/twitter.common.python-0.5.9-py2-none-any.whl/twitter/common/python/installer.py",
line 24, in function_wrapper
>     raise Installer.InstallFailure('Failed to install %s' % self._source_dir)
> InstallFailure: Failed to install /tmp/tmpeni7Ym/setuptools-2.2
> {code}
> When we run it again, the following test fail.
> {code}
> src.test.python.apache.thermos.core.test_runner_integration                     .....
  FAILURE
> {code}
> Refer to the attachments for verbose output and complete test failures. I confirmed the
workspace and build environment is clean, before running the tests.
> {code}
> rm -rf ~/.pants.d .pants.d build-support
> git checkout -- build-support
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message