aurora-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AURORA-583) test failures due to apparent pants issue
Date Wed, 16 Jul 2014 00:21:04 GMT

    [ https://issues.apache.org/jira/browse/AURORA-583?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14062923#comment-14062923
] 

Hudson commented on AURORA-583:
-------------------------------

SUCCESS: Integrated in Aurora #434 (See [https://builds.apache.org/job/Aurora/434/])
AURORA-583: Upgrade to public release of pants (wickman: rev 272fc2635be11c064c7c93e3fc1268398a5cd708)
* pants
* build-support/pex


> test failures due to apparent pants issue
> -----------------------------------------
>
>                 Key: AURORA-583
>                 URL: https://issues.apache.org/jira/browse/AURORA-583
>             Project: Aurora
>          Issue Type: Bug
>          Components: Build, Testing
>            Reporter: Kevin Sweeney
>            Assignee: brian wickman
>            Priority: Blocker
>             Fix For: 0.5.0
>
>
> While attempting to cut -rc1 I ran into the following pants issue
> {noformat}
> ~/src/apache-aurora-0.5.0-rc1-incubating % ./build-support/jenkins/build.sh
> + date
> Tue Jul 15 10:29:42 PDT 2014
> + ./gradlew -Pq clean build
> Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=utf8
> :clean
> :about
> :bootstrapThrift UP-TO-DATE
> :checkPython
> :generateSources
> :compileGeneratedJava
> Note: Some input files use unchecked or unsafe operations.
> Note: Recompile with -Xlint:unchecked for details.
> :processGeneratedResources UP-TO-DATE
> :generatedClasses
> :compileJava
> Note: Writing file:/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/dist/classes/main/com/twitter/common/args/apt/cmdline.arg.info.txt.2
> :processResources
> :classes
> :jar
> :assemble
> :jsHint UP-TO-DATE
> :checkstyleMain
> :compileTestJava
> :processTestResources
> :testClasses
> :checkstyleTest
> :findbugsGenerated
> :findbugsMain
> :findbugsTest
> :licenseGenerated UP-TO-DATE
> :licenseMain UP-TO-DATE
> :licenseTest UP-TO-DATE
> :license UP-TO-DATE
> :pmdMain
> :test
> Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=utf8
> Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=utf8
> Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=utf8
> Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=utf8
> :jacocoTestReport
> Coverage report generated: file:////Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/dist/reports/jacoco/test/html/index.html
> :check
> :build
> BUILD SUCCESSFUL
> Total time: 3 mins 24.649 secs
> + ./pants src/test/python:all -vxs
> Build operating on top level addresses: set([BuildFileAddress(src/test/python/BUILD,
all)])
> ========================================================== test session starts ===========================================================
> platform darwin -- Python 2.6.8 -- py-1.4.21 -- pytest-2.5.2 -- /System/Library/Frameworks/Python.framework/Versions/2.6/bin/python2.6
> plugins: cov, timeout
> collected 2 items
> src/test/python/apache/thermos/common/test_pathspec.py:20: test_legacy_task_roots PASSED
> src/test/python/apache/thermos/common/test_pathspec.py:27: test_legacy_log_dirs PASSED
> ======================================================== 2 passed in 0.02 seconds ========================================================
> Failed to run test!
> Traceback (most recent call last):
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/pantsbuild.pants-0.0.17-py2.7.egg/pants/backend/python/test_builder.py",
line 180, in _run_python_tests
>     builder = chroot.dump()
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/pantsbuild.pants-0.0.17-py2.7.egg/pants/backend/python/python_chroot.py",
line 187, in dump
>     conn_timeout=self._conn_timeout)
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/pantsbuild.pants-0.0.17-py2.7.egg/pants/backend/python/resolver.py",
line 100, in resolve_multi
>     platform=platform)
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/resolver.py",
line 107, in resolve
>     new_requirements.update(requires(highest_package, requirement))
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/resolver.py",
line 79, in requires
>     dist = obtainer.obtain(package)
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/obtainer.py",
line 158, in obtain
>     dist = super(CachingObtainer, self).obtain(req_or_package)
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/obtainer.py",
line 108, in obtain
>     return self._translate_from([req_or_package])
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/obtainer.py",
line 96, in _translate_from
>     dist = self._translator.translate(package)
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/translator.py",
line 44, in translate
>     dist = tx.translate(package)
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/translator.py",
line 116, in translate
>     return DistributionHelper.distribution_from_path(target_path)
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/util.py",
line 50, in distribution_from_path
>     distributions = list(find_distributions(path))
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/finders.py",
line 61, in __call__
>     for dist in finder(importer, path_item, only=only):
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/finders.py",
line 203, in find_wheels_in_zip
>     dist = wheel_from_metadata(path_item, metadata)
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.deps/twitter.common.python-0.5.8-py2.7.egg/twitter/common/python/finders.py",
line 165, in wheel_from_metadata
>     pkg_info = Parser().parsestr(metadata.get_metadata(pkg_resources.DistInfoDistribution.PKG_INFO))
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.bootstrap/pkg_resources.py",
line 1405, in get_metadata
>     return self._get(self._fn(self.egg_info, name))
>   File "/Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/build-support/pants-0.0.17.pex/.bootstrap/pkg_resources.py",
line 1469, in _get
>     return self.loader.get_data(path)
> ZipImportError: bad local file header in /Users/ksweeney/src/apache-aurora-0.5.0-rc1-incubating/.pants.d/python/eggs/coverage-3.7.1-cp26-none-macosx_10_9_intel.whl
> src.test.python.apache.aurora.client.hooks.non_hooked_api                       .....
EXCEPTION
> src.test.python.apache.thermos.common.test_pathspec                             .....
  SUCCESS
> {noformat}
> Looks like pants is building a corrupt coverage wheel somehow? Rerunning it I get the
same error consistently.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message