aurora-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AURORA-186) rename thermos_executor to aurora_executor
Date Fri, 21 Feb 2014 19:55:20 GMT

    [ https://issues.apache.org/jira/browse/AURORA-186?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13908746#comment-13908746
] 

Hudson commented on AURORA-186:
-------------------------------

SUCCESS: Integrated in Aurora #128 (See [https://builds.apache.org/job/Aurora/128/])
AURORA-186: rename ThermosExecutor to AuroraExecutor, clean up thermos-isms from ExecutorBase
(wickman: rev e6cd6a9eaa2f0a9a38ec710765bd4b36df085a09)
* src/main/python/apache/aurora/executor/BUILD
* src/main/python/apache/aurora/executor/bin/BUILD
* src/test/python/apache/aurora/executor/test_thermos_executor.py
* src/main/python/apache/aurora/executor/aurora_executor.py
* src/test/python/apache/aurora/executor/BUILD
* src/main/python/apache/aurora/executor/executor_base.py
* src/test/python/apache/thermos/common/BUILD
* src/main/python/apache/aurora/executor/bin/thermos_executor_main.py
* src/main/python/apache/aurora/executor/thermos_executor.py
* src/main/python/apache/aurora/executor/gc_executor.py
* src/main/python/apache/aurora/executor/thermos_task_runner.py
* src/main/python/apache/aurora/executor/__init__.py


> rename thermos_executor to aurora_executor
> ------------------------------------------
>
>                 Key: AURORA-186
>                 URL: https://issues.apache.org/jira/browse/AURORA-186
>             Project: Aurora
>          Issue Type: Task
>          Components: Executor, Technical Debt
>            Reporter: brian wickman
>            Assignee: brian wickman
>
> thermos_executor is no longer thermos-specific.  there are some vestiges of thermos-specific
task bits and states e.g. in executor_base that were missed in the open-source split, but
they should be removed.  i'd love to see this done before our first public release.
> instead, thermos should be treated as a plugin to the aurora executor, much like all
the health managers are now plugins.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message