aurora-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tobias Weingartner (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AURORA-43) Rename maintenance commands to have a consistent prefix
Date Thu, 06 Feb 2014 01:35:05 GMT

     [ https://issues.apache.org/jira/browse/AURORA-43?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tobias Weingartner updated AURORA-43:
-------------------------------------

    Description: 
Let's make the drain/maintenance commands have a common prefix, preferably something short.
 I propose the following in a man page format:
{noformat}
SYNOPSIS
  host_status [-f filename] cluster [host ...]
  host_deactivate [-f filename] cluster [host ...]
  host_drain [-f filename] cluster [host ...]
  host_activate [-f filename] cluster [host ...]

DESCRIPTION
  host_status
    Print the drain status of each supplied host.

  host_deactivate
    The list of hosts is marked for maintenance, and will be de-prioritized
    from consideration for scheduling.  Note, they are not removed from
    consideration, and may still schedule tasks if resources are very scarce.
    Usually you would mark a larger set of machines for drain, and then do
    them in batches within the larger set, to help drained tasks not land on
    future hosts that will be drained shortly in subsequent batches.

  host_drain
    The list of hosts is drained and marked in a drained state.  This will kill
    off any tasks currently running on these hosts, as well as prevent future
    tasks from scheduling on these hosts while they are drained.

  host_activate
    The list of hosts is marked as not in a drained state anymore.  This will
    allow normal scheduling to resume on the given list of hosts.

OPTIONS
  -f, --file filename
    Provide a filename (you can specify stdin using "-") containing the list of
    hosts to perform the given action on.  No hosts performs nothing.
{noformat}

  was:
Let's make the drain/maintenance commands have a common prefix, preferably something short.
 I propose the following in a man page format:
{noformat}
SYNOPSIS
  host_status [-f filename] cluster [host ...]
  host_deactivate [-f filename] cluster [host ...]
  host_drain [-f filename] cluster [host ...]
  host_activate [-f filename] cluster [host ...]

DESCRIPTION
  host_status
    Print the drain status of each supplied host.

  host_deactivate
    The list of hosts is marked for maintenance, and will be de-prioritized
    from consideration for scheduling.  Note, they are not removed from
    consideration, and may still schedule tasks if resources are very scarce.
    Usually you would mark a larger set of machines for drain, and then do
    them in batches within the larger set, to help drained tasks not land on
    future hosts that will be drained shortly in subsequent batches.

  host_drain
    The list of hosts is drained and marked in a drained state.  This will kill
    off any tasks currently running on these hosts, as well as prevent future
    tasks from scheduling on these hosts while they are drained.

  host_activate
    The list of hosts is marked as not in a drained state anymore.  This will
    allow normal scheduling to resume on the given list of hosts.

OPTIONS
  -f, --file filename
    Provide a filename (you can specify stdin using "-") containing the list of
    hosts to perform the given action on.  No hosts performs nothing.
  -s, --size N
    Give the size of each batch done in parallel during the drain_script.
  -b, --by function
    Give a function to specify the type of grouping you wish to happen.
{noformat}


> Rename maintenance commands to have a consistent prefix
> -------------------------------------------------------
>
>                 Key: AURORA-43
>                 URL: https://issues.apache.org/jira/browse/AURORA-43
>             Project: Aurora
>          Issue Type: Task
>          Components: Reliability, SRE
>            Reporter: Tobias Weingartner
>            Priority: Trivial
>              Labels: newbie
>
> Let's make the drain/maintenance commands have a common prefix, preferably something
short.  I propose the following in a man page format:
> {noformat}
> SYNOPSIS
>   host_status [-f filename] cluster [host ...]
>   host_deactivate [-f filename] cluster [host ...]
>   host_drain [-f filename] cluster [host ...]
>   host_activate [-f filename] cluster [host ...]
> DESCRIPTION
>   host_status
>     Print the drain status of each supplied host.
>   host_deactivate
>     The list of hosts is marked for maintenance, and will be de-prioritized
>     from consideration for scheduling.  Note, they are not removed from
>     consideration, and may still schedule tasks if resources are very scarce.
>     Usually you would mark a larger set of machines for drain, and then do
>     them in batches within the larger set, to help drained tasks not land on
>     future hosts that will be drained shortly in subsequent batches.
>   host_drain
>     The list of hosts is drained and marked in a drained state.  This will kill
>     off any tasks currently running on these hosts, as well as prevent future
>     tasks from scheduling on these hosts while they are drained.
>   host_activate
>     The list of hosts is marked as not in a drained state anymore.  This will
>     allow normal scheduling to resume on the given list of hosts.
> OPTIONS
>   -f, --file filename
>     Provide a filename (you can specify stdin using "-") containing the list of
>     hosts to perform the given action on.  No hosts performs nothing.
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message