aurora-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Robinson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AURORA-43) Rename maintenance commands to have a consistent prefix
Date Wed, 05 Feb 2014 17:36:10 GMT

    [ https://issues.apache.org/jira/browse/AURORA-43?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13892333#comment-13892333
] 

David Robinson commented on AURORA-43:
--------------------------------------

s/drain_status/host_status/
s/drain_mark/host_deactivate/
s/drain_start/host_drain/
s/drain_end/host_activate/

I don't think drain_script belongs here, it should be a separate tool that uses these primitives
(status/deactivate/drain/activate) to accomplish its goals.

> Rename maintenance commands to have a consistent prefix
> -------------------------------------------------------
>
>                 Key: AURORA-43
>                 URL: https://issues.apache.org/jira/browse/AURORA-43
>             Project: Aurora
>          Issue Type: Task
>          Components: Reliability, SRE
>            Reporter: Tobias Weingartner
>            Priority: Trivial
>              Labels: newbie
>
> Let's make the drain/maintenance commands have a common prefix, preferably something
short.  I propose the following in a man page format:
> {noformat}
> SYNOPSIS
>   drain_status [-f filename] cluster [host ...]
>   drain_script [-f filename] [-s N] [-b function] cluster script [host ...]
>   drain_mark [-f filename] cluster [host ...]
>   drain_start [-f filename] cluster [host ...]
>   drain_end [-f filename] cluster [host ...]
> DESCRIPTION
>   drain_status
>     Print the drain status of each supplied host.
>   drain_script
>     Perform a fully scripted drain cycle.  This includes doing the equivalent
>     of doing a 'drain_start' for each batch, and once the batch is drained,
>     running the given script file with the input being the list of hosts within
>     the current batch.  After the script exits successfully, 'drain_end' will be
>     run on the current batch before moving on to subsequent batches.
>     If the script returns a non-zero exit status, the full operation is aborted.
>   drain_mark
>     The list of hosts is marked for maintenance, and will be de-prioritized
>     from consideration for scheduling.  Note, they are not removed from
>     consideration, and may still schedule tasks if resources are very scarce.
>     Usually you would mark a larger set of machines for drain, and then do
>     them in batches within the larger set, to help drained tasks not land on
>     future hosts that will be drained shortly in subsequent batches.
>   drain_start
>     The list of hosts is drained and marked in a drained state.  This will kill
>     off any tasks currently running on these hosts, as well as prevent future
>     tasks from scheduling on these hosts while they are drained.
>   drain_end
>     The list of hosts is marked as not in a drained state anymore.  This will
>     allow normal scheduling to resume on the given list of hosts.
> OPTIONS
>   -f, --file filename
>     Provide a filename (you can specify stdin using "-") containing the list of
>     hosts to perform the given action on.  No hosts performs nothing.
>   -s, --size N
>     Give the size of each batch done in parallel during the drain_script.
>   -b, --by function
>     Give a function to specify the type of grouping you wish to happen.
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message