aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erb, Stephan" <Stephan....@blue-yonder.com>
Subject Re: Build failed in Jenkins: aurora-packaging-nightly #570
Date Wed, 08 Feb 2017 09:37:23 GMT
Caused by Centos mirror trouble https://bugs.centos.org/view.php?id=12793&nbn=1

On 08/02/2017, 01:38, "Apache Jenkins Server" <jenkins@builds.apache.org> wrote:

    See <https://builds.apache.org/job/aurora-packaging-nightly/570/>
    
    ------------------------------------------
    [...truncated 880 lines...]
      Verifying  : libxslt-1.1.28-5.el7.x86_64                               93/140 
      Verifying  : systemd-sysv-219-30.el7_3.6.x86_64                        94/140 
      Verifying  : libICE-1.0.9-2.el7.x86_64                                 95/140 
      Verifying  : subversion-devel-1.7.14-10.el7.x86_64                     96/140 
      Verifying  : libgnome-keyring-3.8.0-3.el7.x86_64                       97/140 
      Verifying  : libcurl-devel-7.29.0-35.el7.centos.x86_64                 98/140 
      Verifying  : freetype-2.4.11-12.el7.x86_64                             99/140 
      Verifying  : perl-podlators-2.5.1-3.el7.noarch                        100/140 
      Verifying  : apr-util-devel-1.5.2-6.el7.x86_64                        101/140 
      Verifying  : alsa-lib-1.1.1-1.el7.x86_64                              102/140 
      Verifying  : mpfr-3.1.1-4.el7.x86_64                                  103/140 
      Verifying  : perl-Filter-1.49-3.el7.x86_64                            104/140 
      Verifying  : dwz-0.11-3.el7.x86_64                                    105/140 
      Verifying  : perl-Socket-2.010-4.el7.x86_64                           106/140 
      Verifying  : cyrus-sasl-devel-2.1.26-20.el7_2.x86_64                  107/140 
      Verifying  : pakchois-0.4-10.el7.x86_64                               108/140 
      Verifying  : rsync-3.0.9-17.el7.x86_64                                109/140 
      Verifying  : fipscheck-1.4.1-5.el7.x86_64                             110/140 
      Verifying  : less-458-9.el7.x86_64                                    111/140 
      Verifying  : gcc-c++-4.8.5-11.el7.x86_64                              112/140 
      Verifying  : initscripts-9.49.37-1.el7.x86_64                         113/140 
      Verifying  : perl-Exporter-5.68-3.el7.noarch                          114/140 
      Verifying  : perl-constant-1.27-2.el7.noarch                          115/140 
      Verifying  : perl-PathTools-3.40-5.el7.x86_64                         116/140 
      Verifying  : 1:perl-Pod-Escapes-1.04-291.el7.noarch                   117/140 
      Verifying  : expat-devel-2.1.0-10.el7_3.x86_64                        118/140 
      Verifying  : libcom_err-devel-1.42.9-9.el7.x86_64                     119/140 
      Verifying  : libffi-devel-3.0.13-18.el7.x86_64                        120/140 
      Verifying  : apr-1.4.8-3.el7.x86_64                                   121/140 
      Verifying  : subversion-1.7.14-10.el7.x86_64                          122/140 
      Verifying  : perl-Thread-Queue-3.02-2.el7.noarch                      123/140 
      Verifying  : 1:perl-Pod-Simple-3.28-4.el7.noarch                      124/140 
      Verifying  : perl-Time-Local-1.2300-2.el7.noarch                      125/140 
      Verifying  : libdb-devel-5.3.21-19.el7.x86_64                         126/140 
      Verifying  : perl-Pod-Perldoc-3.20-4.el7.noarch                       127/140 
      Verifying  : copy-jdk-configs-1.2-1.el7.noarch                        128/140 
      Verifying  : glibc-devel-2.17-157.el7_3.1.x86_64                      129/140 
      Verifying  : xorg-x11-fonts-Type1-7.5-9.el7.noarch                    130/140 
      Verifying  : 1:perl-Error-0.17020-2.el7.noarch                        131/140 
      Verifying  : libXfont-1.5.1-2.el7.x86_64                              132/140 
      Verifying  : flex-2.5.37-3.el7.x86_64                                 133/140 
      Verifying  : cyrus-sasl-2.1.26-20.el7_2.x86_64                        134/140 
      Verifying  : openssh-clients-6.6.1p1-33.el7_3.x86_64                  135/140 
      Verifying  : kernel-headers-3.10.0-514.6.1.el7.x86_64                 136/140 
      Verifying  : perl-Getopt-Long-2.40-2.el7.noarch                       137/140 
      Verifying  : zip-3.0-11.el7.x86_64                                    138/140 
      Verifying  : 1:java-1.8.0-openjdk-1.8.0.121-0.b13.el7_3.x86_64        139/140 
      Verifying  : libgomp-4.8.5-11.el7.x86_64                              140/140 
    
    Installed:
      apr-devel.x86_64 0:1.4.8-3.el7                                                
      cyrus-sasl-devel.x86_64 0:2.1.26-20.el7_2                                     
      flex.x86_64 0:2.5.37-3.el7                                                    
      gcc.x86_64 0:4.8.5-11.el7                                                     
      gcc-c++.x86_64 0:4.8.5-11.el7                                                 
      git.x86_64 0:1.8.3.1-6.el7_2.1                                                
      java-1.8.0-openjdk-devel.x86_64 1:1.8.0.121-0.b13.el7_3                       
      krb5-devel.x86_64 0:1.14.1-27.el7_3                                           
      libcurl-devel.x86_64 0:7.29.0-35.el7.centos                                   
      libffi-devel.x86_64 0:3.0.13-18.el7                                           
      make.x86_64 1:3.82-23.el7                                                     
      openssl.x86_64 1:1.0.1e-60.el7                                                
      patch.x86_64 0:2.7.1-8.el7                                                    
      python-devel.x86_64 0:2.7.5-48.el7                                            
      rpm-build.x86_64 0:4.11.3-21.el7                                              
      subversion-devel.x86_64 0:1.7.14-10.el7                                       
      unzip.x86_64 0:6.0-16.el7                                                     
      wget.x86_64 0:1.14-13.el7                                                     
      which.x86_64 0:2.20-7.el7                                                     
      zlib-devel.x86_64 0:1.2.7-17.el7                                              
    
    Dependency Installed:
      alsa-lib.x86_64 0:1.1.1-1.el7                                                 
      apr.x86_64 0:1.4.8-3.el7                                                      
      apr-util.x86_64 0:1.5.2-6.el7                                                 
      apr-util-devel.x86_64 0:1.5.2-6.el7                                           
      bzip2.x86_64 0:1.0.6-13.el7                                                   
      copy-jdk-configs.noarch 0:1.2-1.el7                                           
      cpp.x86_64 0:4.8.5-11.el7                                                     
      cyrus-sasl.x86_64 0:2.1.26-20.el7_2                                           
      dwz.x86_64 0:0.11-3.el7                                                       
      elfutils.x86_64 0:0.166-2.el7                                                 
      expat-devel.x86_64 0:2.1.0-10.el7_3                                           
      file.x86_64 0:5.11-33.el7                                                     
      fipscheck.x86_64 0:1.4.1-5.el7                                                
      fipscheck-lib.x86_64 0:1.4.1-5.el7                                            
      fontconfig.x86_64 0:2.10.95-10.el7                                            
      fontpackages-filesystem.noarch 0:1.44-8.el7                                   
      freetype.x86_64 0:2.4.11-12.el7                                               
      gdb.x86_64 0:7.6.1-94.el7                                                     
      giflib.x86_64 0:4.1.6-9.el7                                                   
      glibc-devel.x86_64 0:2.17-157.el7_3.1                                         
      glibc-headers.x86_64 0:2.17-157.el7_3.1                                       
      gnutls.x86_64 0:3.3.24-1.el7                                                  
      groff-base.x86_64 0:1.22.2-8.el7                                              
      initscripts.x86_64 0:9.49.37-1.el7                                            
      iproute.x86_64 0:3.10.0-74.el7                                                
      iptables.x86_64 0:1.4.21-17.el7                                               
      java-1.8.0-openjdk.x86_64 1:1.8.0.121-0.b13.el7_3                             
      java-1.8.0-openjdk-headless.x86_64 1:1.8.0.121-0.b13.el7_3                    
      javapackages-tools.noarch 0:3.4.1-11.el7                                      
      kernel-headers.x86_64 0:3.10.0-514.6.1.el7                                    
      keyutils-libs-devel.x86_64 0:1.5.8-3.el7                                      
      less.x86_64 0:458-9.el7                                                       
      libICE.x86_64 0:1.0.9-2.el7                                                   
      libSM.x86_64 0:1.2.2-2.el7                                                    
      libX11.x86_64 0:1.6.3-3.el7                                                   
      libX11-common.noarch 0:1.6.3-3.el7                                            
      libXau.x86_64 0:1.0.8-2.1.el7                                                 
      libXcomposite.x86_64 0:0.4.4-4.1.el7                                          
      libXext.x86_64 0:1.3.3-3.el7                                                  
      libXfont.x86_64 0:1.5.1-2.el7                                                 
      libXi.x86_64 0:1.7.4-2.el7                                                    
      libXrender.x86_64 0:0.9.8-2.1.el7                                             
      libXtst.x86_64 0:1.2.2-2.1.el7                                                
      libcom_err-devel.x86_64 0:1.42.9-9.el7                                        
      libdb-devel.x86_64 0:5.3.21-19.el7                                            
      libedit.x86_64 0:3.0-12.20121213cvs.el7                                       
      libfontenc.x86_64 0:1.1.2-3.el7                                               
      libgnome-keyring.x86_64 0:3.8.0-3.el7                                         
      libgomp.x86_64 0:4.8.5-11.el7                                                 
      libjpeg-turbo.x86_64 0:1.2.90-5.el7                                           
      libkadm5.x86_64 0:1.14.1-27.el7_3                                             
      libmnl.x86_64 0:1.0.3-7.el7                                                   
      libmodman.x86_64 0:2.0.1-8.el7                                                
      libmpc.x86_64 0:1.0.1-3.el7                                                   
      libnetfilter_conntrack.x86_64 0:1.0.4-2.el7                                   
      libnfnetlink.x86_64 0:1.0.1-4.el7                                             
      libpng.x86_64 2:1.5.13-7.el7_2                                                
      libproxy.x86_64 0:0.4.11-10.el7                                               
      libselinux-devel.x86_64 0:2.5-6.el7                                           
      libsepol-devel.x86_64 0:2.5-6.el7                                             
      libstdc++-devel.x86_64 0:4.8.5-11.el7                                         
      libverto-devel.x86_64 0:0.2.5-4.el7                                           
      libxcb.x86_64 0:1.11-4.el7                                                    
      libxslt.x86_64 0:1.1.28-5.el7                                                 
      lksctp-tools.x86_64 0:1.0.17-2.el7                                            
      m4.x86_64 0:1.4.16-10.el7                                                     
      mpfr.x86_64 0:3.1.1-4.el7                                                     
      neon.x86_64 0:0.30.0-3.el7                                                    
      nettle.x86_64 0:2.7.1-8.el7                                                   
      openldap-devel.x86_64 0:2.4.40-13.el7                                         
      openssh.x86_64 0:6.6.1p1-33.el7_3                                             
      openssh-clients.x86_64 0:6.6.1p1-33.el7_3                                     
      pakchois.x86_64 0:0.4-10.el7                                                  
      pcre-devel.x86_64 0:8.32-15.el7_2.1                                           
      perl.x86_64 4:5.16.3-291.el7                                                  
      perl-Carp.noarch 0:1.26-244.el7                                               
      perl-Encode.x86_64 0:2.51-7.el7                                               
      perl-Error.noarch 1:0.17020-2.el7                                             
      perl-Exporter.noarch 0:5.68-3.el7                                             
      perl-File-Path.noarch 0:2.09-2.el7                                            
      perl-File-Temp.noarch 0:0.23.01-3.el7                                         
      perl-Filter.x86_64 0:1.49-3.el7                                               
      perl-Getopt-Long.noarch 0:2.40-2.el7                                          
      perl-Git.noarch 0:1.8.3.1-6.el7_2.1                                           
      perl-HTTP-Tiny.noarch 0:0.033-3.el7                                           
      perl-PathTools.x86_64 0:3.40-5.el7                                            
      perl-Pod-Escapes.noarch 1:1.04-291.el7                                        
      perl-Pod-Perldoc.noarch 0:3.20-4.el7                                          
      perl-Pod-Simple.noarch 1:3.28-4.el7                                           
      perl-Pod-Usage.noarch 0:1.63-3.el7                                            
      perl-Scalar-List-Utils.x86_64 0:1.27-248.el7                                  
      perl-Socket.x86_64 0:2.010-4.el7                                              
      perl-Storable.x86_64 0:2.45-3.el7                                             
      perl-TermReadKey.x86_64 0:2.30-20.el7                                         
      perl-Text-ParseWords.noarch 0:3.29-4.el7                                      
      perl-Thread-Queue.noarch 0:3.02-2.el7                                         
      perl-Time-HiRes.x86_64 4:1.9725-3.el7                                         
      perl-Time-Local.noarch 0:1.2300-2.el7                                         
      perl-constant.noarch 0:1.27-2.el7                                             
      perl-libs.x86_64 4:5.16.3-291.el7                                             
      perl-macros.x86_64 4:5.16.3-291.el7                                           
      perl-parent.noarch 1:0.225-244.el7                                            
      perl-podlators.noarch 0:2.5.1-3.el7                                           
      perl-srpm-macros.noarch 0:1-8.el7                                             
      perl-threads.x86_64 0:1.87-4.el7                                              
      perl-threads-shared.x86_64 0:1.43-6.el7                                       
      python-javapackages.noarch 0:3.4.1-11.el7                                     
      python-lxml.x86_64 0:3.2.1-4.el7                                              
      redhat-rpm-config.noarch 0:9.1.0-72.el7.centos                                
      rsync.x86_64 0:3.0.9-17.el7                                                   
      subversion.x86_64 0:1.7.14-10.el7                                             
      subversion-libs.x86_64 0:1.7.14-10.el7                                        
      systemd-sysv.x86_64 0:219-30.el7_3.6                                          
      sysvinit-tools.x86_64 0:2.88-14.dsf.el7                                       
      trousers.x86_64 0:0.3.13-1.el7                                                
      ttmkfdir.x86_64 0:3.0.9-42.el7                                                
      tzdata-java.noarch 0:2016j-1.el7                                              
      xorg-x11-font-utils.x86_64 1:7.5-20.el7                                       
      xorg-x11-fonts-Type1.noarch 0:7.5-9.el7                                       
      zip.x86_64 0:3.0-11.el7                                                       
    
    Complete!
     ---> 60883efe7c4d
    Removing intermediate container 5a5c5e684afc
    Step 4 : ADD build.sh /build.sh
     ---> 5f9735e21812
    Removing intermediate container e8298fbbd4c5
    Successfully built 5f9735e21812
    + mkdir -p /scratch/src
    + cd /scratch
    + tar --strip-components 1 -C src -xf /src.tar.gz
    + cp -R /specs/rpm .
    + cd rpm
    ++ echo 0.18.0-SNAPSHOT.2017.02.08
    ++ tr - _
    + export AURORA_VERSION=0.18.0_SNAPSHOT.2017.02.08
    + AURORA_VERSION=0.18.0_SNAPSHOT.2017.02.08
    + make srpm
    rm -rf /dist/rpmbuild
    mkdir -p /dist/rpmbuild/BUILD
    mkdir -p /dist/rpmbuild/BUILDROOT
    mkdir -p /dist/rpmbuild/RPMS
    mkdir -p /dist/rpmbuild/SOURCES
    mkdir -p /dist/rpmbuild/SRPMS
    cp /src.tar.gz /dist/rpmbuild/SOURCES/apache-aurora-0.18.0_SNAPSHOT.2017.02.08.tar.gz
    cp SOURCES/* /dist/rpmbuild/SOURCES
    rpmbuild  \
    	--define "_topdir /dist" \
    	--define "_builddir %{_topdir}/rpmbuild/BUILD" \
    	--define "_buildrootdir %{_topdir}/rpmbuild/BUILDROOT" \
    	--define "_rpmdir %{_topdir}/rpmbuild/RPMS" \
    	--define "_srcrpmdir %{_topdir}/rpmbuild/SRPMS" \
    	--define "_specdir %(pwd)" \
    	--define "_sourcedir  %{_topdir}/rpmbuild/SOURCES" \
    	--define "AURORA_VERSION 0.18.0_SNAPSHOT.2017.02.08" \
    	--define "AURORA_INTERNAL_VERSION 0.18.0-SNAPSHOT" \
    	--define "MESOS_VERSION 1.1.0" \
    	--nodeps -bs aurora.spec
    warning: bogus date in %changelog: Mon Jun 21 2016 Apache Aurora <dev@aurora.apache.org>
0.13.0-1.el7
    Wrote: /dist/rpmbuild/SRPMS/aurora-scheduler-0.18.0_SNAPSHOT.2017.02.08-1.el7.centos.aurora.src.rpm
    + yum-builddep -y ../../../dist/rpmbuild/SRPMS/aurora-scheduler-0.18.0_SNAPSHOT.2017.02.08-1.el7.centos.aurora.src.rpm
    Loaded plugins: fastestmirror, ovl
    Enabling base-source repository
    Enabling extras-source repository
    Enabling updates-source repository
    http://vault.centos.org/centos/7/os/Source/repodata/repomd.xml: [Errno 14] HTTP Error
404 - Not Found
    Trying other mirror.
    To address this issue please refer to the below knowledge base article 
    
    https://access.redhat.com/articles/1320623
    
    If above article doesn't help to resolve this issue please create a bug on https://bugs.centos.org/
    
    failure: repodata/repomd.xml from base-source: [Errno 256] No more mirrors to try.
    http://vault.centos.org/centos/7/os/Source/repodata/repomd.xml: [Errno 14] HTTP Error
404 - Not Found
    Build step 'Execute shell' marked build as failure
    Skipped archiving because build is not successful
    

Mime
View raw message