aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Sirois <j...@conductant.com>
Subject Re: [VOTE] Release Apache Aurora 0.12.0 rpms
Date Sun, 13 Mar 2016 02:56:35 GMT
On Sat, Mar 12, 2016 at 2:02 PM, Erb, Stephan <Stephan.Erb@blue-yonder.com>
wrote:

> I'll try to spin up a centos box myself and see how that goes.
>

Re-running through testing I hit more basic roadblocks.  Its not clear to
me what / how I built here!
Apologies for wasting your time - I'll get in a few patches and then kick
off a new vote.


>
> > Dependency naming aside, i think we should omit docker from our
> > dependencies, as it really should be a mesos dep if anything.  *I can
> send
> > a patch for that if others agree.*
>
> We also have to be more diligent in tracking the Mesos version we depend
> on. It already got out of date here [1] and here [2].
>
> [1]
> https://github.com/apache/aurora/blob/master/docs/installing.md#mesos-on-centos-7
> [2]
> https://github.com/apache/aurora-packaging/blob/master/specs/rpm/aurora.spec#L41
>
>
> ________________________________________
> From: Bill Farner <wfarner@apache.org>
> Sent: Saturday, March 12, 2016 21:34
> To: dev@aurora.apache.org; jsirois@apache.org
> Subject: Re: [VOTE] Release Apache Aurora 0.12.0 rpms
>
> -1
>
> I'm had trouble getting these to work.  I used the vagrant environment
> here:
> https://github.com/apache/aurora-packaging/tree/master/test/rpm/centos-7


Agreed - this vote has failed.


>
>
> *Executor:*
> $ sudo rpm -ivh aurora-executor-0.12.0-1.el7.centos.aurora.x86_64.rpm
> error: Failed dependencies:
> docker is needed by aurora-executor-0.12.0-1.el7.centos.aurora.x86_64
>
> Apparently the official docker package is called docker-engine
> https://docs.docker.com/engine/installation/linux/centos/
>
> Dependency naming aside, i think we should omit docker from our
> dependencies, as it really should be a mesos dep if anything.  *I can send
> a patch for that if others agree.*
>
> *Scheduler:*
> I had trouble getting the scheduler to start, it exits due to an uncaught
> exception in the main thread, and unfortunately a stack trace doesn't turn
> up in journalctl.  We need to figure out why the errors don't show up,
> possibly in conjunction with addressing the items below.
>
> Doing some investigation, i noticed something strange - JAVA_OPTS (set in
> /etc/sysconfig/aurora) doesn't make it to the process launched by systemd.
> It seems to be discarded when /usr/bin/aurora-scheduler-startup calls
> /usr/lib/aurora/bin/aurora-scheduler.  Other variables (e.g.
> AURORA_SCHEDULER_OPTS) propagate fine.  I've probably been staring at this
> too long and am missing something obvious, but i'm not making sense of it.
>
> Sidestepping the above issue, i discovered 2 reasons the scheduler won't
> start up:
> - Default backup dir /var/lib/aurora/scheduler/backups does not exist,
> insufficient permission to create
>
> - Fails to load the mesos native lib
> aurora-scheduler-startup[8500]: Failed to load native Mesos library from
> /usr/lib;/usr/lib64
> I was able to fix this by removing ;/usr/lib64 from
> -Djava.library.path='/usr/lib;/usr/lib64', alternatively by removing the
> library.path setting and exporting LD_LIBRARY_PATH=/usr/lib.
>
> Happy to pitch in on fixing these issues, curious what folks think of the
> items above, especially the JAVA_OPTS issue.
>
>
>
> On Fri, Mar 11, 2016 at 1:31 PM, John Sirois <jsirois@apache.org> wrote:
>
> > Pinging this VOTE and noting that the close is Monday at 11am Mountain
> > time.
> >
> > Please test!
> >
> > On Wed, Mar 9, 2016 at 11:03 AM, John Sirois <jsirois@apache.org> wrote:
> >
> > >
> > >
> > > On Wed, Mar 9, 2016 at 11:00 AM, John Sirois <jsirois@apache.org>
> wrote:
> > >
> > >> I propose that we accept the following artifacts as the official rpm
> > packaging
> > >> for Apache Aurora 0.12.0.
> > >>
> > >> *https://dl.bintray.com/john-sirois/aurora/centos-7/
> > >> <https://dl.bintray.com/john-sirois/aurora/centos-7/>*
> > >>
> > >> The Aurora rpm packaging includes the following:
> > >> ---
> > >> The CHANGELOG is viewable at:
> > >> *
> >
> https://git1-us-west.apache.org/repos/asf?p=aurora-packaging.git;a=log;h=refs/heads/0.12.x;hp=refs/heads/0.11.x
> > >> <
> >
> https://git1-us-west.apache.org/repos/asf?p=aurora-packaging.git;a=log;h=refs/heads/0.12.x;hp=refs/heads/0.11.x
> > >*
> > >>
> > >> The branch used to create the packaging is:
> > >>
> > >>
> >
> https://git1-us-west.apache.org/repos/asf?p=aurora-packaging.git;a=tree;h=refs/heads/0.12.x
> > >>
> > >> The packages are available at:
> > >> *https://dl.bintray.com/john-sirois/aurora/centos-7/
> > >> <https://dl.bintray.com/john-sirois/aurora/centos-7/>*
> > >>
> > >> The GPG keys used to sign the packages are available at:
> > >> https://dist.apache.org/repos/dist/release/aurora/KEYS
> > >>
> > >> Please download, verify, and test.
> > >>
> > >> The vote will close on Mon, 14 Mar 2016 11:00:00 -0700
> > >>
> > >> [ ] +1 Release these as the deb packages for Apache Aurora 0.12.0
> > >>
> > >
> > > Correction - "Release these as the rpm packages for Apache Aurora
> 0.12.0"
> > >
> > > [ ] +0
> > >> [ ] -1 Do not release these artifacts because...
> > >> ---
> > >>
> > >>
> > > And again, copypasta - "Please consider verifying these rpms using the
> > > install guide:"
> > >
> > > Please consider verifying these debs using the install guide:
> > >>   https://github.com/apache/aurora/blob/master/docs/installing.md
> > >>
> > >>
> > >> I'd like to kick off voting with my own +1
> > >>
> > >
> > >
> >
>



-- 
John Sirois
303-512-3301

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message