aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kunal Thakar <kun...@uber.com>
Subject Backwards incompatible change
Date Tue, 02 Feb 2016 19:04:35 GMT
Hi,

The change to remove --enable-announce flag as one of the parameters to the
executor (
https://github.com/apache/aurora/commit/9faec2f0544e6165357105e4cd01c682cb316a00)
breaks backwards compatibility. There is no easy way to roll out this
upgrade as the previous version requires the flag and the new version won't
work with the flag. I am guessing that this is an unintended consequence of
twitter.common.app rejecting unknown arguments. The --enable-announce flag
needs to be made optional before removing it from the code.

Regards,
Kunal

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message