aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Farner <wfar...@apache.org>
Subject Re: issue running docker container in aurora
Date Fri, 11 Sep 2015 00:06:24 GMT
I believe we sorted Siddharth out over IRC today, by switching to 14.04 as
his base image for now.

The most challenging issue was finding the right deps for libmesos under
0.23.0 in ubuntu 12.04.  This is still unsolved, so if anyone has a
Dockerfile based on 12.04 that works with vanilla libmesos.so from 0.23.0,
i'd love to know!

Also relevant is https://issues.apache.org/jira/browse/AURORA-1487, which
will correct a misleading example file we have in our source tree.

On Thu, Sep 10, 2015 at 8:15 AM, Siddharth, Gopalsamy <
gsiddharth@paypal.com.invalid> wrote:

> Hi Dan ,
>
> Still the same issue ,
>
> This looks like some other dependency , can you please help ?
>
> Thanks
> -Siddharth
>
> On 9/10/15, 9:42 PM, "Siddharth, Gopalsamy" <gsiddharth@paypal.com> wrote:
>
> >Thank you Dan ,
> >
> >Let me try it out and get back
> >
> >Thanks
> >-Siddharth
> >
> >On 9/10/15, 9:33 PM, "Dan Norris" <dnorris@apache.org> wrote:
> >
> >>Siddharth,
> >>
> >>You also need to have the Mesos build dependencies in your Docker
> >>container
> >>before trying to run it. Add a line to your Dockerfile like the following
> >>and you should be able to launch your task:
> >>
> >>RUN apt-get install -y python libsvn-dev libapr1-dev libcurl4-nss-dev
> >>libsasl2-dev
> >>
> >>
> >>
> >>On Thu, Sep 10, 2015 at 7:49 AM, Siddharth, Gopalsamy <
> >>gsiddharth@paypal.com.invalid> wrote:
> >>
> >>> Hi dev folks ,
> >>>
> >>> I am using mesos 23.0 and aurora 0.9.0 which I installed from deb
> >>>files.
> >>>
> >>> Is there any requirement for thermos_executor to have libmesos /python
> >>>2.7
> >>> in the container because the container runs fine out of aurora?
> >>>
> >>> i`m seeing a few errors of the following :
> >>>
> >>> MesosDriver not found :
> >>>
> >>> Writing log files to disk in /mnt/mesos/sandbox
> >>> thermos_executor: error: Could not load MesosExecutorDriver!
> >>> twitter.common.app debug: main sys.exited
> >>> twitter.common.app debug: Shutting application down.
> >>> twitter.common.app debug: Running exit function for twitter.common.log
> >>> (Logging subsystem.)
> >>> twitter.common.app debug: Finishing up module teardown.
> >>> twitter.common.app debug:   Active thread: <_MainThread(MainThread,
> >>> started 140023471273728)>
> >>> twitter.common.app debug: Exiting cleanly.
> >>>
> >>> Python - exceptions :
> >>>
> >>> Traceback (most recent call last):
> >>>   File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main
> >>>     "__main__", fname, loader, pkg_name)
> >>>   File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
> >>>     exec code in run_globals
> >>>   File "/mnt/mesos/sandbox/thermos_executor/__main__.py", line 24, in
> >>> <module>
> >>>   File
> >>>
> >>>"/mnt/mesos/sandbox/thermos_executor/.bootstrap/_pex/pex_bootstrapper.py
> >>>"
> >>>,
> >>> line 4, in <module>
> >>> ImportError: No module named contextlib
> >>>
> >>> Thanks
> >>> -Siddharth
> >>>
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message