aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hussein Elgridly <huss...@broadinstitute.org>
Subject Re: installing Aurora client fails
Date Wed, 11 Mar 2015 21:52:16 GMT
These errors look very similar, if not identical, to the ones I saw over
our devops' shoulder while he found it incredibly difficult to build Aurora
in a Docker container. (He gave up eventually.)

You say you made it to the end of the build process - if you did indeed
build the client successfully, it should be in dist/aurora.pex relative to
the root of the Git repo.

Hussein Elgridly
Senior Software Engineer, DSDE
The Broad Institute of MIT and Harvard


On 11 March 2015 at 17:43, Bill Farner <wfarner@apache.org> wrote:

> This isn't a solution, but are you able to try to repro in a 14.04 image?
> This is the environment we are currently qualifying development against, so
> a failure there might generate more data for us.
>
> -=Bill
>
> On Wed, Mar 11, 2015 at 1:55 PM, Andras Kerekes <
> andras.kerekes@ishisystems.com> wrote:
>
> > Hi All,
> >
> >
> >
> > I'm trying to install the Aurora CLI client and no success. I'm on Ubuntu
> > 12.04 running in VirtualBox.
> >
> >
> >
> > First I tried the 0.7.0-incubating tarball version that I have downloaded
> > from the Download section. Ran './pants binary
> > src/main/python/apache/aurora/client/cli:aurora' command which at the end
> > of the output had this:
> >
> >
> >
> > Installing
> >
> /home/osboxes/aurora/apache-aurora-0.7.0-incubating/build-support/pants.venv/lib/python2.7/site-packages/twitter.common.util-0.3.2-py2.7-nspkg.pth
> >
> >   Found existing installation: setuptools 3.6
> >
> >     Uninstalling setuptools:
> >
> >       Successfully uninstalled setuptools
> >
> > Successfully installed Markdown Pygments ansicolors cov-core coverage
> > docutils lockfile pantsbuild.pants pex psutil py pystache pytest
> pytest-cov
> > requests six twitter.common.collections twitter.common.config
> > twitter.common.confluence twitter.common.contextutil
> > twitter.common.decorators twitter.common.dirutil twitter.common.lang
> > twitter.common.log twitter.common.options twitter.common.process
> > twitter.common.string twitter.common.threading twitter.common.util
> > setuptools
> >
> > Cleaning up...
> >
> >
> >
> > Exception message: [Errno 2] No such file or directory
> >
> >
> >
> > After this, whatever I tried pants gave the 'Exception message: [Errno 2]
> > No such file or directory' error message without any further information,
> > not even if I turned on verbose output.
> >
> >
> >
> > Then I cloned the git repo (https://github.com/apache/incubator-aurora)
> > and ran './pants binary src/main/python/apache/aurora/client/cli:aurora'.
> > This time the build failed with a different error:
> >
> >
> >
> > IOError: invalid Python installation: unable to open
> >
> /home/osboxes/aurora/checkout/incubator-aurora/build-support/pants.venv/local/include/python2.7/pyconfig.h
> > (No such file or directory)
> >
> >
> >
> > After copying
> >
> /home/osboxes/aurora/checkout/incubator-aurora/build-support/pants.venv/include
> > into
> >
> /home/osboxes/aurora/checkout/incubator-aurora/build-support/pants.venv/local
> > the build finished successfully, but now I don't know how to run the
> client.
> >
> >
> >
> > What do I miss?
> >
> >
> >
> > Thanks,
> >
> > Andras
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message