aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Wickman <wick...@twopensource.com>
Subject Re: build errors
Date Wed, 15 Oct 2014 18:16:41 GMT
You should probably update thrift_wrapper_codegen.py to #!/usr/bin/env
python2.7

The 'flags=' keyword argument was added in 2.7, and I believe 2.6 is the
default for CentOS 6.

On Wed, Oct 15, 2014 at 11:09 AM, Bill Farner <wfarner@apache.org> wrote:

> What's your python version?  Presumably this would fail on any sha for the
> last few months.
>
> -=Bill
>
> On Wed, Oct 15, 2014 at 10:29 AM, Joe Stein <joe.stein@stealth.ly> wrote:
>
> > Hi, I am getting this error trying to build (and run) Aurora on Centos
> 6.5
> >
> > Traceback (most recent call last):
> >   File
> > "src/main/python/apache/aurora/tools/java/thrift_wrapper_codegen.py",
> line
> > 712, in <module>
> >     'values': value_entries(struct.values),
> >   File
> > "src/main/python/apache/aurora/tools/java/thrift_wrapper_codegen.py",
> line
> > 708, in value_entries
> >     'doc': trim_doc_text(v[1])} for v in values])
> >   File
> > "src/main/python/apache/aurora/tools/java/thrift_wrapper_codegen.py",
> line
> > 529, in trim_doc_text
> >     return re.sub('^\s*\*\s*', '', doc, flags=re.MULTILINE) if doc else
> > None
> > TypeError: sub() got an unexpected keyword argument 'flags'
> > :generateSources FAILED
> >
> >
> > I have thrift installed
> >
> > /opt/apache/incubator-aurora$thrift -version
> > Thrift version 0.9.1
> >
> > /*******************************************
> >  Joe Stein
> >  Founder, Principal Consultant
> >  Big Data Open Source Security LLC
> >  http://www.stealth.ly
> >  Twitter: @allthingshadoop <http://www.twitter.com/allthingshadoop>
> > ********************************************/
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message