aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Smith <yasumo...@gmail.com>
Subject Re: Upgrading pants to pin our python interpreter version
Date Mon, 06 Oct 2014 19:48:54 GMT
Hi all,

This is out for review at https://reviews.apache.org/r/26378/. Once it
ships, we'll be enforcing python2.7 by default.

Please reach out with any questions/concerns!

Thanks,
Joe

On Mon, Sep 22, 2014 at 12:16 PM, Joe Smith <yasumoto7@gmail.com> wrote:

> Hi all,
>
> Pants is cutting a new release
> <https://github.com/pantsbuild/pants/issues/597>, which includes the
> ability to specify a repo-wide interpreter compatibility
> <https://github.com/pantsbuild/pants/issues/483>. Using this feature will
> decrease the impact the environment has on which interpreter is used (see
> AURORA-462 <https://issues.apache.org/jira/browse/AURORA-462> and
> AURORA-585 <http://URORA-585> for examples) and overall increases
> reliability and reproducibility.
>
> As it ships, I propose we pin our repo at python27- are there any concerns
> with doing so? Some people may still be using python26, in which case you
> can change pants.ini to specify 2.6 on your internal fork, since we
> largely decided to no longer support it
> <http://mail-archives.apache.org/mod_mbox/incubator-aurora-dev/201407.mbox/%3cCA+y6w6oumbGoJy2B+KHS4UoPAQELSsCX4VhHa3ejakkijPb0bQ@mail.gmail.com%3e>
> .
>
> Thanks!
> Joe
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message