aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Cohen <jco...@twopensource.com>
Subject Re: pants release to support overriding interpreter
Date Fri, 19 Sep 2014 21:46:02 GMT
Hi Bhuvan,

I'm trying to work with the pants devs to get a new release cut that
includes the repo-wide interpreter requirement. Stay tuned!

Cheers,

Joshua

On Thu, Sep 18, 2014 at 8:04 PM, Bhuvan Arumugam <bhuvan@apache.org> wrote:

> This is more of pants/pex question. I'm posting it here, as most of
> pants/pex expert hang around in this group.
>
> I wish to build aurora_client.pex using py2.7. Both py2.6 and py2.7
> exist in my PATH and pex is built always using py2.6. I went through
> https://github.com/pantsbuild/pants/issues/483, and looks like it's
> fixed in pants. In the new world, we could override it in
> [python-setup].interpreter_requirement. But a new pants version is not
> released yet.
>
> Here is what I tried:
>
> a) build pants using py2.7 and use it to build aurora_client.pex. The
> aurora_client.pex is always built using py2.6
> b) use --python argument to pex command in ./build-support/pex. No luck.
>
> When can we expect a newer version of pants?
> When aurora will be updated to use that version of pants?
> In the meantime, is there any way to override the interpreter that go into
> pex?
>
> --
> Regards,
> Bhuvan Arumugam
> www.livecipher.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message