aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeffrey Davis <jeffrey.n.da...@gmail.com>
Subject Problems building Thermos
Date Fri, 05 Sep 2014 15:32:32 GMT
Hi all -

I'm in the process of setting up a ~small aurora cluster, but appear to
have hit a wall w/ building Thermos.  I tried breaking out portions of
aurorabuild.sh, but I think there's an environmental issue that's been
preset on the vagrant image.

For both:
     ./pants src/main/python/apache/aurora/executor/bin:gc_executor
     ./pants src/main/python/apache/aurora/executor/bin:thermos_executor
I get an error for an unmet dependency for mesos-0.19.1.  From KTS in the
IRC room, I tried creating a third_party directory at the base of the
project and dropping the file mesos-0.19.1-py2.7-linux-x86_64.egg there,
but to no avail.  I tried various naming combinations, and also tried
dropping it in /3rdparty/python ( from the project base ).

Finally, for
   ./pants src/main/python/apache/aurora/executor/bin:thermos_runner
I get:
     Untranslateable: Package SourcePackage(u'
https://pypi.python.org/packages/source/p/psutil/psutil-1.1.2.tar.gz#md5=fe9c9a3ed95fe6564acf8b4500c7b5da
')

My apologies if this is a vacuous question - my python skill set is not
that great, so trying to understand how pants puts things together has been
challenging.

For our current system, uname -a gives: Linux vagrant-debian-wheezy
3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux

Thanks!

Jeff Davis

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message